HEXNCPY(9) DragonFly Kernel Developer's Manual HEXNCPY(9) NAME hexncpy -- Converts a set of values into an ASCII string. SYNOPSIS #include char * hexncpy(const u_char *inb, int inlen, char *outb, int outlen, const char *sep); DESCRIPTION hexncpy() function creates an ASCII string representing values passed in inb. Parameter inlen specifies the number of values for inb. Resulting ASCII string is stored in outb whose maximum size is determined by outlen. Each converted value can be separated by the character specified in sep. If NULL is specified no separator will be used. RETURN VALUES hexncpy() function returns a pointer to the string containing the ASCII representation of the values passed in inb. HISTORY The hexncpy() function first appeared in DragonFly 3.3 DragonFly 3.3 February 5, 2012 DragonFly 3.3