test1
Changelog: From origin/DragonFly_RELEASE_4_6 to origin/DragonFly_RELEASE_4_8
Contributed software
- (4baf3da6) - gcc47: Backport objc fix from gcc trunk.
- (a547914c) - Merge branch 'vendor/LESS'
- (09598512) - libncurses: Avoid -Woverflow in baud rates.
- (ddaf9f4a) - wpa_supplicant: Avoid cpp warning during buildworld.
- (eee86d5a) - binutils 2.25 linkers: Set default interpreter to valid path
- (a9fa9459) - Initial import of binutils 2.27 on vendor branch
- (09219ee0) - Import missing source needed to enable plugin support in utilities.
- (11650561) - binutils225: Make plugin dir overridable at compile time.
- (62af0394) - gcc47: Do not include empty header.
- (e656dc90) - Merge remote-tracking branch 'origin/vendor/BINUTILS227'
- (03f62010) - less(1): Fix type mismatches in different objects.
- (b4603dcf) - TRE: Fix const discard issue for all compilers.
- (c211e079) - bmake: upgrade version 20141111 => 20160818
- (0c8a2822) - gcc47: Fix misplaced NULL usage in strings.
- (4eab6968) - kernel - set default locale name for smbfs
- (d5d214b7) - Update gcc-50 to SVN version 239798 (gcc-5-branch)
- (5f76495b) - gcc50: Add alternative variant of pthread presence checking.
- (727fc32d) - Merge branch 'vendor/BINUTILS225'
- (c1d69b4e) - tcsh - Work around gcc-5 bug
- (6496ec5c) - gcc47: Suppress last codegen warning.
- (9b760066) - Update less from version 471 to 481
- (f445c897) - Update to bmake-20160818 on the vendor branch
- (9a8f24bf) - Merge branch 'vendor/BMAKE'
- (c8008567) - Retire the binutils-2.24.
- (14cfea99) - binutil227: Add DF README's and local modifications.
- (6b9ba3e8) - bootstrap: Expand BOOTSTRAPPING case to avoid warning.
- (385754ab) - Merge branch 'vendor/GCC50'
- (e02a905d) - libncurses: Avoid warning when calling cgetent().
- (6ebf792c) - contrib/bmake: remove 2 local modifications to prepare for merge
Cryptography
- (5b245968) - build - Remove openssl from base (is now permanently replaced by ressl)
- (66ceb5e9) - libressl: Few local modifications for netcat.
- (4188afc7) - Merge branch 'vendor/LIBRESSL'
- (a310eb9b) - libcrypto(3): Remove some cruft from when we supported 32-bit.
- (94089e80) - Merge branch 'vendor/OPENSSL'
- (f20408c2) - Update libressl README.DRAGONFLY for v2.4.4
- (497a44b0) - Add a openbsd-compat file for latest import.
- (e00185f1) - Patch ssh vendor code for xauth's default location.
- (7475be11) - sshd - Fix default password authentication (2)
- (e9778795) - Import OpenSSH-7.3p1.
- (0acf6c5c) - Update LibreSSL from version 2.4.2 => 2.4.3
- (609bcd71) - Merge branch 'vendor/OPENSSH'
- (f0ea6a7a) - Remove most local modifications from OpenSSH.
- (c064523c) - Allow make.conf to override ssh's xauth location.
- (f73288b8) - LibreSSL: complete update v2.4.2 => v2.4.3
- (a25ca6f6) - Merge branch 'vendor/LIBRESSL'
- (d9ccbcc9) - build - use libressl md5.h for kernel
- (f5b1c8a1) - Import LibreSSL v2.4.2 to vendor branch
- (57de8ae1) - OpenSSH: Suppress warning on login_getcapstr().
- (4bde49b7) - sshd(8): Disable tunneled cleartext passwords.
- (4821a1d6) - Merge branch 'vendor/OPENSSH'
- (bd84e838) - security/libressl: Fix ECDSA P-256 timing attack vulnerability
- (1852dacb) - OpenSSH: Suppress last warning in session.c
- (4a22becb) - Unbreak build.
- (88828e76) - sshd - Fix default password authentication
- (72be967a) - OpenSSH: Add missing prototypes and bump WARNS to 3.
- (1920ada3) - Merge branch 'vendor/LIBRESSL'
- (5adaeadc) - Import OpenSSL-1.0.2h.
- (530c17a6) - Update LibreSSL from version 2.4.3 => 2.4.4
Devices
- (0b985ce1) - sys/dev/disk/dm: Cleanup
- (68fad459) - if_iwm - Advertise full-offload scan support, fixes scan while associated.
- (0104ee1f) - if_iwm - Move iwm_read_firmware() call into iwm_attach().
- (05475029) - sdhci - Simplify SDHCI_PRESENT_STATE register loop in sdhci_start_command().
- (bb480ca6) - if_iwm - Remove 1s delay after fw loading. Can't reproduce issues on AC8260.
- (74d41163) - if_iwm - change the check for ADD_STA status, use IWM_ADD_STA_STATUS_MASK.
- (89f579e9) - if_iwm - Enable Energy Based Scan (EBS).
- (d078c812) - if_iwm - Remove a couple of unneeded IWM_UCODE_TLV_FLAGS_* flags.
- (89bbdcc9) - drm/linux: Clean-up pci_resource_start()
- (f62d3258) - Revert "if_iwm - SCAN_ABORT_UMAC response doesn't use a wide id"
- (e8560f8d) - if_iwm - The iwm_prepare_card_hw() in iwm_attach() is only needed on 8K hw.
- (f0e79919) - ahci - Add workarounds for Marvell 88SE9215
- (0510b0ee) - syscons - Add need_unlock arg to sc_clean_up and sc_wait_scrn_saver_stop.
- (b8c69b44) - kernel/ecc: Add MODULE_VERSION()s.
- (d7002a79) - if_iwm - Add basic powermanagement support via ifconfig wlan0 powersave.
- (085e37a0) - if_iwm - Sync rs (rate-selection) API definitions from Linux iwlwifi.
- (81b3c1fe) - if_iwm - Adjust if_iwm_sta.h prototypes, don't pass iwm_node to rm_sta().
- (50787d03) - if_iwm - Get rid of iwm_disable_rx_dma, just use iwm_pcie_rx_stop directly.
- (33ded22a) - if_iwm - Remove more old unused scan API definitions.
- (5e446442) - if_iwm - Improve reliability of iwm_release on disassociation a bit.
- (b26dd4db) - if_iwm - Use ic->ic_tq for iwm_endscan_cb instead of a private taskqueue.
- (a639f788) - acpi - Incidental MPSAFE
- (66d55158) - kernel/efirt: Hook efirt.ko into the build.
- (c009bade) - if_iwm - Get rid of another usage of the IWM_DEFAULT_MACID/_COLOR constant.
- (c662db9a) - sys/dev/disk/dm: Remove dm_table_init_target() call with NULL
- (8d327fcc) - drm/i915: Mark a DragonFly-specific change as such
- (8cd49a21) - drm/i915: build firmware handling code
- (8b61fe77) - drm/i915/trace: Add missing include files
- (cbb82693) - if_iwm - Sync valid_tx_ant and valid_rx_ant mask handling with iwlwifi.
- (250a1c33) - if_iwm - Sync iwm_nvm_read_chunk() function with Linux iwlwifi.
- (b9794186) - if_iwm - Remove two duplicate const qualifiers.
- (31517ca9) - hyperv: Implement cpucounters.
- (94b50139) - if_iwm - Handle AUTH->SCAN/INIT and ASSOC->SCAN/INIT better
- (53a009d6) - if_iwm - Factor out and improve iwm_mvm_scan_rxon_flags() in if_iwm_scan.c.
- (1e0cf8ec) - if_iwm - Use notification wait API to wait for calibration to complete.
- (2427de16) - if_iwm - Add some pcie device stop code from iwlwifi. Adjust a delay.
- (710fdd01) - if_iwm - Remove OpenBSD-specific comment. Beautify pci cfg space accesses.
- (92cc3b9f) - if_iwm - Remove some unneeded #include-s from all .c files.
- (75895a53) - if_iwm - Sync statistics API definitions with Linux iwlwifi.
- (aba448de) - if_iwm - Refuse connection to APs with beacon interval < 16.
- (f88ab372) - if_iwm - Add iwm_nic_unlock() calls missing from previous commit.
- (b8674cff) - drm - Fix subtle plane masking bug.
- (b484d09d) - if_iwm - Add scan abort functions, to properly cancel a running scan.
- (f414b8da) - if_iwm - Get rid of unneeded IWM_FWDMASEGSZ and IWM_FWMAXSIZE constants
- (35f0e6c8) - if_iwm - Simplify device id matching code a bit.
- (fccb38ab) - drm/linux: Add sign_extend64()
- (7f03b76b) - sdhci - Add a new interface method, get_card_present.
- (37d17953) - kernel/mmcsd: Add some dummy values for d_nheads and d_secpertrack.
- (5df2bc49) - if_iwm - Use htole16 for policy field in struct iwm_time_event_cmd_v2.
- (62a4e795) - if_iwm - Switch arguments from iwm_node* to iwm_vap* in if_iwm_power.c.
- (fefad7a7) - drm/radeon: Replace some spinlocks by lockmgr locks
- (f95003b8) - if_iwm - Remove support for fw older than -17 and -22
- (19b2b39d) - sys/dev/disk/dm: Remove obvious/redundant/disabled kprintfs
- (47431072) - kernel - Add trackpoint and elantech mouse support (2)
- (52c3adbe) - if_iwm - Clean up if_iwm_power.c a bit. Fix iwm_power_scheme debug print.
- (efb7d4eb) - if_iwm - Very basic DTS thermal sensor support (prints temp as debug msg).
- (1f7ae36f) - re: Fix typo for disabling txcsum.
- (a8e9a5d2) - kernel/iwm: Fix building into the kernel without IWM_DEBUG.
- (612855b1) - if_iwm - Fix typo in commit a7697ea01c11fd493aec52260a02f31df680eb91.
- (5b210ee3) - Move efirt.ko's source to sys/dev/misc/efirt.
- (5a9835ae) - cpuctl(4): Require write rights for CPUCTL_MSRSBIT and CPUCTL_MSRCBIT.
- (cc6703ed) - vkernel: Prevent clang optimizing out the traps.
- (ff4d1fc3) - if_iwm - Get rid of some gratuitous constant renaming wrt. Linux iwlwifi.
- (0e589b85) - ahci - Adjust a few things
- (288315ff) - if_iwm - Fix comments and struct definition for struct iwm_sf_cfg_cmd.
- (99e67e8c) - i386 removal, part 53/x: Remove the code of the fe(4) driver too.
- (1e59d133) - drm/linux: Implement tasklets
- (39f8331b) - if_iwm - Sync nvm parsing code with Linux iwlwifi.
- (c6b72188) - hyperv: Implement Hyper-V reference TSC cputimer.
- (69b57ec3) - drm/linux: add sg_pcopy_{from/to}_buffer()
- (917ec290) - drm: Sync drm_crtc.c with Linux 4.6
- (5d6b465e) - if_iwm - Update firmware rs table, instead of indexing the table in tx cmds.
- (9e3c8f63) - sdhci - Add some missing register constants, and dump some more registers.
- (082d190b) - kernel - Fix minor bug in powermng
- (19bd59e4) - sys/dev/disk/dm: Make init/destroy handlers optional
- (ef688ceb) - if_iwm - Recognize IWM_FW_PAGING_BLOCK_CMD wide cmd response correctly.
- (a8524cc6) - if_iwm - Store paging_mem_size field in firmware image information struct.
- (138b1116) - drm/radeon: restore the fbdev mode in lastclose
- (420099d0) - if_iwm - Fix iwm_poll_bit() error value check in iwm_attach().
- (de7995a5) - if_iwm - Change 2nd arg of iwm_phy_db_set_section() to struct iwm_rx_packet.
- (c4743e25) - if_iwm - Remove unused fw_totlen field in struct iwm_fw_sects.
- (2c2175b3) - sdhci - Use pci_alloc_1intr in sdhci pci attachement.
- (6a6d661d) - drm/linux: Add acpi/video.h
- (3b7fc5aa) - if_iwm - Allow listening on both chains/atennas to get diversity.
- (9ed6fcdb) - acpi: Save I/O ports for I/O ports range, as long as its reasonable.
- (fd4f9de8) - if_iwm - Add firmware API definitions for TX power commands.
- (6a895867) - drm/linux: Add kstrtouint()
- (b8bd6cd7) - if_iwm - Properly implement iwm_wme_update callback function.
- (76dba67c) - kernel/adv: Fix extern type to match the real one.
- (0a797ca8) - kernel/if_wi: Unlock before returning.
- (b5eb43f0) - if_iwm - Process multiple frames per RX buffer.
- (67b5e090) - if_iwm - Check sc->sc_attached flag in suspend/resume callbacks.
- (82437db0) - drm/linux: kernel_ulong_t is defined in linux/mod_devicetable.h
- (a9e978f7) - drm/linux: add atomic64_cmpxchg()
- (ce43f57f) - if_iwm - Implement apmg_wake_up_wa workaround properly for 7000 family.
- (757eecf0) - if_iwm - Make ucode capabilities and api flags handling more like iwlwifi.
- (e79101d4) - drm/linux: add few ida_* functions.
- (ab1d3efc) - if_iwm - Add the BSS's basic rates to iwm's LQ command, not all the rates.
- (5c64209c) - drm/linux: Add get_nr_swap_pages()
- (cc624b16) - syscons - Fix syscons with UEFI fb when drm fb is registered during boot.
- (98dffbe0) - hyperv: Reorder the Hyper-V TSC initialization a bit.
- (70f95ad1) - i386 removal, part 61/x: Adjust some further #ifdefs.
- (c7dca6a7) - drm: Partial revert of "drm: Sync drm_crtc.c with Linux 4.6"
- (1f249c98) - if_iwm - Use iwm_mvm_scan_stop_wait to properly abort scans.
- (20825c8a) - ath_hal: Add FCC6_FCCA regulatory domain (0x0014)
- (83a1185e) - if_iwm - Move iwm_dma_contig_alloc/free functions to ifiwm_util.c.
- (fa3094db) - drm/linux: implement div64_u64_rem() helper in math64.h
- (28d082dd) - sys/dev/disk/dm: Make dmdebug() print func
- (f1c11ff5) - drm/i915: Fix typo in get_bdb_header(), fixes vbt validity check.
- (2d695c09) - sdhci - Use the right capability field for printing the bus width.
- (e98ee77a) - if_iwm - Synchronize firmware loading code with Linux iwlwifi.
- (a7697ea0) - if_iwm - Sync IWM_MVM_ALIVE waiting and start_fw handling with iwlwifi.
- (848ab9a3) - if_iwm - Use chan list from ieee80211_scan_state for scan, not ic_channels.
- (e57b1815) - drm/linux: Add request_firmware_nowait()
- (0e645f47) - vkernel - Fix races in if_vke.c
- (0cb0a810) - if_iwm - Switch 7265D and 3165 devices to 7265D firmware.
- (4b1006a6) - iwm - Reduce gratuitous differences with Linux iwlwifi in struct naming.
- (3e9aaef3) - if_iwm - Remove dead code from iwm_pcie_load_cpu_sections().
- (02b1bea0) - cxm(4): Fix type mismatches on firmware variables.
- (d7ecd68b) - if_iwm - Fix up RSSI calculations for scan results and normal RX operations.
- (d11dcf6a) - drm/linux: Add vmap()
- (fb572d17) - drm: Implement and use Linux struct device
- (347f670a) - drm/linux: Add ktime_get_boottime and ktime_ms_delta()
- (b5cdd806) - if_iwm - Get rid of struct iwm_rx_data argument for iwm_mvm_rx_rx_mpdu.
- (6bf7fbb4) - syscons - Handle kms framebuffer activation better when not in text mode.
- (81d65608) - drm/i915: Set GPU freq to idle_freq initially
- (9b497556) - drm/linux: Add kasprintf and kvasprintf()
- (3370bc55) - if_iwm - Tiny cleanup in iwm_rx_addbuf().
- (dda889ac) - if_iwm - Ignore IWM_DEBUG_LOG_MSG notifications.
- (61f2dcf2) - syscons - Remove unneeded NULL check from register_framebuffer().
- (e54a5ebe) - if_iwm - Remove unused wantresp field in iwm_rx_data struct.
- (aa128dc0) - if_iwm - Already call iwm_mvm_power_update_mac() during SCAN<->AUTH paths.
- (6e31eb98) - drm/linux: Add kmap_to_page()
- (a391a14a) - nvme - Fix BUF_KERNPROC() SMP race
- (c498b1f6) - kernel/if_re: Adjust permissions.
- (711b25be) - if_iwm - Remove wrappers around iwm_dma_contig_free() calls.
- (ae7ab5b6) - hyperv/vmbus: Passthrough interrupt resource allocation to nexus
- (31075e01) - AHCI - Misc fixes
- (8119d5f5) - ahci - Implement FBS for port-multipliers
- (78cabd54) - syscons - Add range check for color value in KDSBORDER ioctl.
- (0cf16dd2) - if_iwm - Move in_phyctxt from struct iwm_node to phy_ctxt in struct iwm_vap.
- (10e8d0d3) - drm/linux: Remove a redundant definition of NSEC_PER_SEC
- (c3c5b993) - drm/linux: Add USEC_PER_MSEC definition
- (d92b8907) - mmcsd - Wasn't quite MPSAFE, fix startup race (2)
- (c62a0e9a) - drm/i915/psr: Try to program link training times correctly
- (d6c667ea) - mrsas - release devq before freeing the sim.
- (84292f0c) - if_iwm - The HW Revision stepping constants should be in if_iwmreg.h.
- (516272d3) - if_iwm - With the previous commits, this DELAY no longer seems to be needed.
- (cef47a9c) - if_iwm - SCAN_ABORT_UMAC response doesn't use a wide id
- (58318c95) - if_iwm - Set command code for PHY_DB as well.
- (f8b03d86) - drm: Use fb_blank hooks from drm_fb_helper.c as a syscons screensaver.
- (c1019b6b) - if_iwm - Sync if_iwm_phy_db code with Linux iwlwifi.
- (ca210820) - if_iwm - Use rates given in struct ieee80211_txparam for non-data transfers.
- (a57bab71) - re: Only limited versions of this chip require explicit padding.
- (0593e39c) - if_iwm - Check for lar_disable tunable, and lar_enabled flag from NVM.
- (5abb6f61) - drm: Invert del_timer_sync return value, to match behaviour in Linux.
- (282d6506) - drm/linux: Add local_clock()
- (056b1c44) - drm/i915/gem: Reduce differences with Linux 4.4
- (d58a6b2f) - if_iwm - Remove some more fields from struct nvm_data which are irrelevant.
- (4d8d6f9d) - if_iwm - Recognize IWM_DTS_MEASUREMENT_NOTIF_WIDE notification.
- (2c995f40) - kernel/vinum: Fix the position of VINUM_LABEL ioctl handling.
- (a3268cb6) - drm - Stabilize broadwell and improve skylake
- (00e94364) - sys/dev/disk/dm: Cleanups
- (475c7069) - kernel - Make gpio and gpio_led MPSAFE
- (08a7ad5a) - if_iwm - Configure the PCIe LTR, fix PCI express capability accesses.
- (b9df4474) - kernel/re: Fix hw.re.phy_mdix_mode tunable.
- (6191bf2c) - corepower: Fix identify method for multi-cpu-package systems
- (e3d653d5) - drm/linux: MODULE_FIRMWARE is defined in linux/module.h
- (bd04c403) - drm/linux: Add clamp_val()
- (6c5470f2) - if_iwm - iwm_{read,write}_prph() don't grab the nic lock in iwm themselves.
- (eb9f4c83) - ahci - Add quirks for Marvell devices
- (144d4fa7) - if_iwm - Fix iwm_poll_bit() usage in iwm_stop_device().
- (96eaecf9) - if_iwm - Move mbuf hacks after sanity checks in iwm_mvm_rx_rx_mpdu().
- (4c45994f) - if_iwm - Only for family 7000 power-down busmaster DMA clocks when stopping.
- (22caf486) - sdhci - Use bus_dmamem_coherent for allocating memory for sdma DMA.
- (03c6e697) - if_iwm - Deduplicate code in iwm_auth() from an if condition.
- (c00575de) - if_iwm - Change UCODE_TLV_API #define-s from bitmasks to indexes.
- (455bd1b1) - sdhci - Fix typo, support bits for drive types A,C,D are in capabilities.
- (ebd4ceab) - if_iwm - Make sure we call iwm_detach_local only once.
- (46d04d11) - ahci - Improve port-multiplier detection
- (6fe294ae) - drm - Fix memory leak in broadwell or later GPUs
- (f77dbd6c) - drm/linux: u64 is unsigned long long
- (76375588) - alc: Sync w/ FreeBSD
- (e8f7d88e) - if_iwm - No need for iwm_assoc() in AUTH->ASSOC transition.
- (a9a1a341) - if_iwm - Remove calib_version field from struct iwm_nvm_data.
- (b8e7ab1b) - if_iwm - Get rid of some more superfluous bus_dmamap_sync calls in rx path.
- (120fda08) - em/emx: Retry interrupt allocation with MSI
- (a4413ab2) - hyperv: Add API to read raw value of Hyper-V timer.
- (f16ef749) - if_iwm - Partly sync if_iwm_binding.c to Linux iwlwifi code.
- (6bc7b4f2) - hyperv/vmbus: Fix interrupt timer detection logic.
- (339d45fd) - if_iwm - Cleanup mbufq draining. Add iwm_xmit_queue_drain() like in iwn(4).
- (ff21100d) - drm/linux: Add ida_simple_get()
- (71310fab) - if_iwm - Fix iwm_mvm_send_cmd_pdu(status) declarations. Make id a uint32t.
- (88af68e6) - syscons - Make sure we draw the terminal border during syscons startup.
- (1d244c81) - if_iwm - Recognize the IWM_UCODE_TLV_FW_MEM_SEG firmware section type.
- (666737f6) - if_iwm - Set correct state in smart-fifo configuration.
- (b7a7bc3c) - drm/i915: Revert DisplayPort fast link training feature
- (7252c37c) - acpi - Incidental MPSAFE (2)
- (c947b0b8) - if_iwm - Update struct iwm_scan_results_notif. Remove old/unused definitions
- (8a5dd778) - if_iwm - Add iwm_mvm_send_lq_cmd() from Linux iwlwifi to if_iwm_util.c.
- (92aa89bf) - mmcsd(4): Declare device D_MPSAFE. Move start_transaction to mmcsd thread.
- (e9348d8e) - mmcsd - Wasn't quite MPSAFE, fix startup race
- (719bf70a) - re: Update to Realtek 1.93
- (dc2e69bd) - if_iwm - Make powersaving more similar to Linux iwlwifi behaviour.
- (cb60f91b) - hyperv: Move commonly shared header files to the module's top dir.
- (2e53e344) - syscons - Clean up log messages for KMS console.
- (8cc03924) - if_iwm - Fix inverted logic in iwm_tx().
- (6f1436aa) - if_iwm - Get rid of SYNC_RESP_STRUCT and SYNC_RESP_PTR macros.
- (928dd978) - drm/i915: Re-apply lost intel_dp.c diff.
- (71187b16) - drm/linux: Improve request_firmware() compatibility
- (d4b0d671) - kernel/psm: Support newer Synaptics touchpads
- (d998b496) - drm/linux: Add cache_line_size()
- (3095bcbd) - drm/i1915: Disable stolen memory support
- (cc8d6ccf) - if_iwm - Use chipset configuration structs like iwlwifi does.
- (2ca88594) - sys/dev/disk/dm: Remove default:break for switch enums on kldload
- (10881df2) - if_iwm - GC unused code from if_iwm_scan.c, copyied from iwn or iwlwifi/dvm.
- (c89787af) - if_iwm - Remove deprecated scan API definitions.
- (43c88c9d) - syscons - Set cons_unavail when blanking framebuffer screen from syscons.
- (061c1d08) - kernel - Re-fix chromebook keyboard
- (e3b1da0f) - kernel - Fix a vty switch/history bug
- (d6dd6e77) - kernel/iwm: Allow IWM_DEBUG to come in via the kernel config too.
- (0e1ba51b) - drm: Sync a few headers with Linux 4.4
- (c11f373c) - drm/linux: add circ_buf.h needed for guc client bits
- (01de5542) - drm/i915: Fix compilation with clang
- (7d74ebe9) - if_iwm - Fix off-by-one check in iwm_read_firmware().
- (338bb82b) - sys/dev/disk/dm: Remove #if0'd dmminphys() from NetBSD
- (41a68322) - sys/dev/disk/dm: Remove dm_dev::dev_type
- (1b7db0e0) - drm/linux: Add linux/kobject.h
- (d1c10ccf) - if_iwm - Sync iwm_read_firmware()'s loop to iwlwifi's code.
- (b40601fa) - sdhci - Use MPSAFE version for the taskqueue and callouts
- (10d5b77b) - if_iwm - Sanity check channel for IEEE80211_CHAN_ANYC in if_iwm_mac_ctxt.c.
Filesystems
- (1ea93af3) - sys/vfs/hammer: Add HAMMER_BLOCKMAP_LAYER2_DOALIGN()
- (513f50d5) - sys/vfs/hammer: Use typedef'd for union hammer_data_ondisk*
- (75e4d787) - sys/vfs/hammer: Change HAMMER_VOLUME_NUMBER_XXX macros to inline functions
- (84c5a984) - hammer - Disallow modifying ioctls when filesystem is read-only
- (877580d2) - sys/vfs/hammer: Use typedef'd for struct hammer_record*
- (4eb78dd2) - sys/vfs/hammer: Add HAMMER_BIGBLOCK_DOALIGN()
- (6416eb03) - sys/vfs/hammer: Add HAMMER_MIN|MAX_ONDISK_LOCALIZATION
- (459a6a40) - sys/vfs/hammer: Add HAMMER_ENCODE_UNDO()
- (cbccd318) - sys/vfs/hammer: Integrate ondisk uint32 reserveds into []
- (6b482339) - sys/vfs/hammer: Use typedef'd for struct hammer_io*
- (0942f1c4) - sys/vfs/hammer: Drop redundant error initialization
- (56bbb861) - sys/vfs/hammer: Use typedef'd for struct hammer_node*
- (000f0f49) - kernel/msdosfs: Sort pathconf cases in msdosfs_pathconf().
- (0dd9c298) - sys/vfs/hammer: Add HAMMER_VOL_BUF_SIZE()
- (5f532f10) - sys/vfs/hammer: Use typedef'd for struct hammer_base_elm*
- (22a0040d) - sys/vfs/hammer: Typedef struct on declaration
- (558bda99) - procfs - don't try to count rss
- (7fb33ff0) - sys/vfs/hammer: Rename HAMMER_STRUCTURE_XXX to HAMMER_IOTYPE_XXX
- (1b0a8c58) - sys/vfs/hammer: Change unused ondisk redo_mtime to reserved
- (18fcc8f1) - buf - Remove B_ORDERED, Incidental CAM MPSAFE (2)
- (ba2be8e9) - sys/vfs/hammer: Use typedef'd for struct hammer_mount*
- (4fcdc8b4) - sys/vfs/hammer: Add hammer_zone_to_iotype()/hammer_io_to_iostring()
- (7af5c3a4) - sys/vfs/hammer: Remove unused struct hammer_io_list
- (2dcf7f7f) - sys/vfs/hammer: Conform to typical hammer code format
- (6ff6b538) - kernel/msdosfs: Add pathconf(3) support for FILESIZEBITS.
- (562d34c2) - sys/vfs/hammer: Use typedef'd for struct hammer_buffer*
- (a003db3d) - sys/vfs/hammer: Add comments on filesystem capacity
- (237baba3) - hammer - remove commented out code, move a biodone()
- (7251986a) - sys/vfs/hammer: Use typedef'd for enum hammer_io_type
- (9bd64fcf) - sys/vfs/hammer: Remove wrong comment
- (b419d3ee) - sys/vfs/hammer: Use typedef'd for struct hammer_volume_ondisk*
- (332c168f) - sys/vfs/hammer: Remove HAMMER_RECTYPE_LOWEST
- (d8b10ae3) - kernel - Fix smbfs readdir and umount
- (7dc46daa) - sys/vfs/hammer: Rename HAMMERIOC_PFS_ITERATE to HAMMERIOC_SCAN_PSEUDOFS
- (8ee21624) - sys/vfs/hammer: Fix comment on lo in direntry
- (af802767) - sys/vfs/hammer: Remove unused HAMMER_IOC_PFS_XXX macros
- (8cf688a7) - sys/vfs/hammer: Fix confusing comment
- (9615af80) - sys/vfs/hammer: Use MIN/MAX macros for B-Tree node's elm base
- (bbc5e78b) - sys/vfs/hammer: Add HAMMER_BUFSIZE_DOALIGN() and variants
- (e0d7dd09) - hammer - Remove global VOP counters
- (b077a45c) - sys/vfs/hammer: Fix wrong comment and unnecessary argument
- (85e11dad) - kernel - Fix NFS sillyrename code
- (5a89e5d1) - smbfs - Fix rename operation
- (e0f42079) - sys/vfs/hammer: Change/Fix ioctl API for HAMMERIOC_PFS_ITERATE
- (96dc2e6f) - sys/vfs/hammer: Use HAMMER_BUFSIZE_DOALIGN() and variants
- (371e4713) - msdosfs - Mount ricoh camera cards
- (f097bffe) - sys/vfs/hammer: Add HAMMER_DATA_DOALIGN() and variants
- (77f7bc0a) - sys/vfs/hammer: Integrate ondisk reserved fields and unused fields
- (50d83294) - sys/vfs/hammer: Fix terminology for undo fifo
- (f6d29b27) - sys/vfs/hammer: Rename misleading macro hammer_is_zone2_mapped_index()
- (c4e15ea8) - sys/vfs/hammer: Add HAMMER_ZONE_LAYER2_NEXT_OFFSET()
- (c577aa50) - sys/vfs/hammer: Add inline CRC functions hammer_crc_get_xxx()
- (d7d5ced7) - sys/vfs/hammer: Fix wrong comment
- (8856c8bd) - sys/vfs/hammer: Add sys/vfs/hammer/hammer_crc.h
- (6831865c) - sys/vfs/hammer: Add hammer_xlate_to_undo()
- (d369f237) - sys/vfs/hammer: Cleanups
- (7f1e2b68) - sys/vfs/hammer: Add ascii-art for volume layout
- (74779181) - hammer2 - Fix deadlocks, bad assertion, improve flushing.
- (e1067862) - sys/vfs/hammer: Use typedef'd for struct hammer_inode*
- (d8fe5ece) - sys/vfs/hammer: Add inline CRC functions for mrec head
- (87d20609) - sys/vfs/hammer: Use typedef'd for struct hammer_transaction*
- (c94d411e) - sys/vfs/hammer: Use HAMMER_MAX_KEY for initial trunc_off values
- (8e4b4a1d) - kernel - Fix directory scanning bug in msdosfs
- (2be0af6e) - sys/vfs/hammer: Use typedef'd for struct hammer_pseudofs_data*
- (961b3eec) - sys/vfs/hammer: Add inline CRC functions for layer1/2
- (b2bafd84) - sbin/newfs_hammer: Add hidden -j option for header junk space
- (87d99cc5) - sys/vfs/hammer: Make the existing CRC functions inline
- (e027fd44) - sys/vfs/hammer: Add inline CRC functions for undo/redo fifo head
- (1743d7ba) - sys/vfs/hammer: Add typedefs for ondisk structures without typedefs
- (5bfc3998) - sys/vfs/hammer: Remove wrong comment
- (38fd96e9) - sys/vfs/hammer: Remove wrong comment
- (f43e824c) - sys/vfs/hammer: Fix comments
- (22837163) - sys/vfs/hammer: Fix numbering of reserved fields for vol0
- (61cc5b39) - sys/vfs/hammer: Remove prototypes for not existing functions
- (053f997d) - sys/vfs/hammer: Use typedef'd for struct hammer_btree_leaf_elm*
- (3ff3ba13) - sys/vfs/hammer: Fix zone/iotype/iostring conversion
- (4168cfe8) - kernel/smbfs: Fix type mismatches for smbfs_pbuf_freecnt.
- (23b37863) - sys/vfs/hammer: Remove redundant function btree_max_elements()
- (c655a349) - sys/vfs/hammer: Mention ondisk fields are in little endian
- (b54756a3) - sys/vfs/hammer: Remove wrong comment
- (a6b7735b) - sys/vfs/hammer: Use typedef'd for struct hammer_volume*
- (d2823dc0) - sys/vfs/hammer: Use HAMMER_HEAD_DOALIGN()
- (f659d161) - sys/vfs/hammer: Change unused PFS ioctl flag to reserved
- (b59ba5b8) - sys/vfs/hammer: Use typedef'd for struct hammer_node_lock*
- (b7f51e3b) - sys/vfs/hammer: Add HAMMER_ZONE_LAYER1_NEXT_OFFSET()
- (20852157) - hammer2 - Revamp flush and xopq mechanism, stabilization
- (e405f42b) - hammer - Try to fix improper DATA CRC error
- (89202d69) - LINT64: Fix buildkernel with WANT_HAMMER2=yes.
GNU
- (ca469380) - libgomp5: Trim sources that create empty objects.
- (44168ca0) - groff: Trim sources that create empty objects.
- (47c94a29) - mdoc.local: Add DragonFly 4.6 for future reference.
- (d36e624f) - diffutils: Trim sources that create empty objects.
- (75c42e2c) - cvs: Use mempcpy() from libc.
- (3c581645) - gcc47: Remove bits/ handling.
- (3ba0a407) - gdb: Trim sources that create empty objects.
- (e8a9e873) - flex: Break the hardlinks to fix quickworld issues.
- (73cfb346) - gcc50: Build lto-wrapper when buildworld is LTO enabled.
- (daf64da7) - binutils225: Honor global CFLAGS.
- (c1e8f2db) - LTO: Prevent -flto being used by host native tools.
- (6028677c) - binutils227: Add build dirs.
- (8ed55295) - gcc50: Fix logic in cxx hostlib.
- (695ff941) - lvm2: Trim sources that create empty objects.
- (7450193e) - gcc47: Allow gcc47 to compile itself at WORLD_CCOPTLEVEL=g.
- (fbb48945) - LTO: Prevent -flto being used by any of libstdc++ stuff.
- (b02d68b2) - LTO: Prevent -flto exposing csu internals when linking v2.
- (c36eae16) - binutils225: Symlink liblto_plugin.so from default base gcc compiler.
- (4da47808) - grep(1): Trim sources that create empty objects.
- (c9d2d51c) - libstdcxx5: Trim sources that create empty objects.
- (e4a1a17a) - gcc47: Disable use of -flto.
- (6cc51cd6) - binutils225: Add plugin support in ar, nm, ranlib.
- (f1f41483) - gcc50: Install liblto_plugin.so as +x.
- (0709fbf4) - gcc50: Compile and install collect2 utility.
- (082b455e) - gcc50: Activate workaround for libgcc_pic.a.
- (0fdf3cc4) - binutils227: Symlink liblto_plugin.so from default base gcc compiler too.
- (92076dcf) - gcc47: Prevent -Wswitch-bool noise.
- (f08f1baa) - bootstrap: Fix old boostrapping issue once and for all.
- (a0163879) - bootstrap: Fix old boostrapping issue once and for all part 2.
- (7b8d9c5b) - binutils225: Trim sources that create empty objects.
- (b4017e00) - LTO: Prevent -flto being used by main gcc libraries.
- (441ae94b) - gcc50: Hook missing source into the libgcc.a.
- (a74bcbde) - libmgmp: Trim sources that create empty objects.
- (16f96020) - libmpfr: Trim sources that create empty objects.
- (b872e4a8) - mdoc.local: Add definition for '.Lb libefivar'.
- (4cad72d0) - gcc50: Upgrade version 5.3.1 => 5.4.1 + 3 months
- (de95169c) - gcc50: Build lto-wrapper even if buildworld is not LTO enabled.
- (49fcfac7) - gold: Fix CFLAGS override.
- (736c49ed) - gcc50: Trim sources that create empty objects.
Games
- (c5e1790f) - backgammon(6): Prevent LTO seeing details for now.
- (57d6ec24) - fortune(6): Resort few fortunes databases.
- (cfe0a42b) - Relocate readline and ncurses headers to /usr/include/priv
- (3410ff94) - fortune(6): Sync fortunes-o with FreeBSD
- (bd5b2c72) - fortune(6): Turn writing to disk a runtime option.
- (dc9541c0) - fortune(6): Remove some dup fortunes.
- (7a5f870a) - fortune(6): Rework manpages.
- (6c5aea60) - fortune(6): Add new fortunes from FreeBSD
- (a2cdfb90) - fortune(6): Use arc4random_uniform(3).
- (43920920) - fortunes: Fix typos in some of the fortunes.
- (e7c38752) - bcd(6): Add decoding option and few extras.
- (f6a9b9c7) - dm(8): Avoid warning on gcc with -flto.
- (29542870) - fortune(6): Fix some typos in the datfiles.
- (017817f0) - fortune(6): Perform some cleanup.
- (24bb1958) - caesar(6): Mention rot13(6) too.
- (cb75653e) - fortune(6): Use argc and argv.
- (f7cdf97a) - fortune(6): Clean up the murphy.
- (31b695b4) - fortune(6): Add FORTUNE_PATH env variable.
- (e3c15a1a) - fortune(6): Fix typos in some of the fortunes.
- (daf83263) - adventure(6): Fix type to match public one.
Kernel
- (01740954) - kernel - Add atomic ops features
- (eba68494) - kernel - Fix bug in socket_wait() (used by samba)
- (95b4dba2) - kernel: Remove unused DIRECTIO option (see 12b70cea73eef6a67).
- (5a3a4cf3) - kernel - Fix mountctl() / unmount race
- (c0739b3c) - kernel - Incidental MPLOCK removal (devfs)
- (dfad150f) - kernel - Default kernel build to -O2
- (582f286d) - kernel - Fix swap issue, implement dynamic pmap PT/PD/PDP deletion (3)
- (c5f0c4c2) - Sync ACPICA with Intel's version 20170119.
- (48e93b2f) - kernel - Cleanup PFIL_MPSAFE
- (25604715) - kernel/usb4bsd: Configure the correct bMaxPacketSize for control endpoints.
- (8e9ad8f9) - kernel - Fix swap issue, implement dynamic pmap PT/PD/PDP deletion (2)
- (b3fef7a1) - kernel - Do a better job locking CAM ref counts
- (54ea00b8) - vkernel - Add COW image capability
- (111c08ac) - Clean up whitespace in a few headers (no functional change).
- (51678651) - kernel - Fix estcpu calculation
- (73b1bfb1) - kernel - Remove unused pmap_list
- (7217e995) - : Remove some duplicate definitions.
- (6b91ee43) - kern: Add cpucounter which returns 64bit monotonic counter.
- (635c9c15) - kernel - Refactor vm_page_alloc() to improve hot pages
- (52df6187) - cputimer: Add more IDs for VMM cputimers.
- (2eca01a4) - kernel - Fix getpid() issue in vfork() when threaded
- (a3946564) - kernel - Reduce size of struct spinlock
- (f1591f08) - boot - Add EFI support for placing /boot in a disklabel's 'a' partition.
- (dc039ae0) - kernel - Change vm_fault_page_quick semantics + vkernel fixes
- (57587a56) - kernel/usb4bsd: Add a quirk for the Corsair STRAFE Gaming keyboard.
- (43931787) - kernel - Remove direct mapping of user buffers to CAM
- (3a05fd2a) - Use ; instead of , where appropriate.
- (70ca95ba) - Expand fpusave union to include x86_64 versions
- (1da659ed) - cam - Fix bus registration race
- (ca88a24a) - kernel - Add vfs.repurpose_enable, adjust B_HASBOGUS
- (d1083e0d) - kernel - Cleanup namecache stall messages on console
- (74351cf4) - /: Fix STDC_VERSION macro.
- (64a757fe) - : Include explicitly for userland.
- (11b27f9d) - kernel: Rename the struct behind device_t to bsd_device
- (cbae2de8) - : Some POSIX adjustments.
- (b5d7e50f) - buildkernel - Fix build issue w/libmd changes
- (9c960153) - kernel - More threaded core dump fixes
- (5947157e) - kernel - Refactor suword, fuword, etc. change vmm_guest_sync_addr()
- (2e2c9b13) - kernel/efirt: Make efirt compilable into the kernel and add to LINT64.
- (90aa054d) - kernel - Cleanup swap comments
- (7fb451cb) - kernel - Fix excessive ipiq recursion (4)
- (4dd1b994) - vkernel - Fix a vkernel lockup on startup
- (07ef76e0) - kernel - Fix bug in physio()
- (75979118) - kernel - Further refactor vmstats, adjust page coloring algorithm
- (53b5cfd6) - kernel - Remove ffs_rawread() (2)
- (a7a03a5f) - kernel - Fix swap issue, implement dynamic pmap PT/PD/PDP deletion
- (94dc1dad) - if_iwm - Add implementation of the notification wait api from iwlwifi.
- (481d12aa) - kernel - Incidental MPLOCK removal (non-performance)
- (c1a70273) - machine/endian.h: Mark bswap functions always inlineable.
- (da2da420) - kernel - Fix bugs in recent RSS/swap commits
- (07fc7b93) - kernel - Slightly reduce extra spinlock ops in pvalloc()
- (2be007da) - efi - Add EFI run-time ABI support (2)
- (8f73b9ee) - kernel - cleanup vfs_cache debugging
- (a7760074) - pc64: Fix typo in wrmsr_safe.
- (f25fc9b7) - drm: Use struct fb_info * as arg for syscons fb restore helper function.
- (50fac53f) - kernel/slaballoc: Separate some parts better that need INVARIANTS.
- (3f961ece) - : Prepare for the removal of from .
- (a3a33e50) - kernel - Fix pmap dynamic deletion code, leave disabled
- (b4315fc7) - Sync ACPICA with Intel's version 20170303.
- (0087561d) - cputimer: Initialize explicitly.
- (38abd253) - kernel/vmx - Add a missing lwkt_reltoken()
- (f773a7d8) - kernel/ddb: Fix type mismatch in different objects.
- (405f56bc) - kernel - Minor cleanup swtch.s
- (73101af2) - kernel - Remove unneeded map token use from the vm_fault path.
- (08309d94) - kernel - Use GDF_VIRTUSER to help measure user% in the vkernel host
- (ae88e4ee) - kernel/pc64: Don't fill uefi framebuffer with 0x77 during early boot.
- (41c7705f) - kernel: Remove useless I586_PMC_GUPROF option.
- (2519e05d) - kernel - Improve exec performance
- (ae1f1544) - kernel - Fix lwp_fork/exit race
- (36968f65) - build - Fix modifying operation to /usr/obj during installworld.
- (326b7fc3) - kernel: Fix compilation
- (e4327e3c) - if_iwm - Revert 8000C firmware (for AC8260) to version 16 for now.
- (1a2e394a) - x86_64: Work around AMD erratum 793 for family 16h, models 00h-0Fh
- (8db0c49d) - : Move warn_unused_result to 3.4
- (0c4341b9) - buf - Remove B_ORDERED, Incidental CAM MPSAFE
- (57cbfb93) - vkernel - Invalidate pte before setting attributes to the vm_page
- (f0181d63) - kernel - Fix namecache race & panic
- (070a58b3) - kernel - Implement CPU localization hinting for low level page allocations
- (0001762f) - kernel - Fix coredump race with threaded processes
- (1e0d343f) - kernel - Fix race with vmspace_entry destroy race
- (0187f435) - kernel - Incidental MPLOCK removal
- (005328d6) - vkernel - Fix pv_entry_count bug
- (34fd616e) - kernel - Fix lwp_fork/exit race (2) (vkernel)
- (743e39a3) - kernel - Add nvme to the default kernel build
- (3522bdfe) - i386 removal, part 52/x: Remove the old cs(4) network driver.
- (4c5fadfd) - : Remove unneeded includes (cleans up namespace).
- (a094cc95) - kernel - Optimize lwp-specific signaling.
- (864231c1) - kernel - Fix VTEXT/open race
- (85aae976) - kernel, world - Remove the remaining vestiges of linux emul
- (91755bdd) - usched: Add USCHED_SET_CPUMASK.
- (1f1a42b5) - sys/boot: Unbreak WORLD_CCVER=gcc47
- (b5eb2428) - kernel - Fix improper user-space access in sys___semctl()
- (8edfbc5e) - kernel - more kmalloc and nlookup performance optimizations
- (82faf793) - kernel - Remove old SCSI drivers - aic, aic7xxx, ahc, ahd
- (d84f6fa1) - kernel - Attempt to fix cluster pbuf deadlock on recursive filesystems
- (afd2da4d) - kernel - Remove PG_ZERO and zeroidle (page-zeroing) entirely
- (82b77854) - hyperv: Reorganize
- (51424739) - kernel - Fix panic/crash in vm_object_page_remove()
- (a96e04f2) - Sync ACPICA with Intel's version 20161117.
- (6acf62db) - kernel - Cleanup macros
- (c2e7bb20) - kernel - Remove mplock from KTRACE paths
- (95be233a) - x86_64: Fix machdep.smp_active sysctl type.
- (74857ad3) - kernel - Fix memcpy assembly ABI
- (6de4cf8a) - vkernel - change hz default, optimize systimer
- (27d11320) - if_iwm - Move struct iwm_cfg chipset configs to if_iwm_7000.c and _8000.c
- (c6051228) - kernel - Validate that previous pte was cleaned.
- (3dd1f60c) - sys/kern: Make struct buf::b_dep a member of union
- (ebf31163) - lwp: vkernel actually uses some lwp_* functions
- (d95d5e03) - vkernel - Fix vmspace_*() call bottleneck
- (ca7dfd3c) - acpi/cst: Keep parsing rest of the GAS, even if the mwait hint is wrong.
- (4c3545b6) - sys/boot: Remove empty source.
- (e989b548) - kernel - Fix races created by a comedy of circumstansces (3)
- (f76ae5a7) - kernel - Fix broken assertion for "pv->pv_m != NULL" panic
- (9002b0d5) - kernel - Refactor cpu localization for VM page allocations (2)
- (93631e64) - cputimer: Reorder fields a bit to avoid implicit padding.
- (55a7854b) - kernel - Refactor struct vmstats and vm_zone
- (fa810433) - LTO: Use CC for kernel linking.
- (d638c6ee) - Sync ACPICA with Intel's version 20170224.
- (bba35d66) - kernel - Deal with lost IPIs (VM related)
- (a17c6c05) - kernel: Add a new vm_object_init()
- (b39d697f) - efi - Add EFI run-time ABI support (3)
- (3576ef4e) - kernel - Modestly reduce default maxvnodes calculation
- (60e8fc88) - Belatedly bump DF version after SSL libraries were privatized
- (240bd9cd) - mmc: With this workaround, both eMMC and sd-card slot on hp x2 210 work
- (1647c7bd) - kernel: Fix the type of 'cmd' in various ioctl functions (int -> u_long).
- (824a4f96) - : Some POSIX adjustments.
- (962f16a7) - kernel - repurpose buffer cache entries under heavy I/O loads
- (79363655) - kernel: Fix GPT detection a bit.
- (992850f4) - lwp: Bump version for shuffle lwp syscalls.
- (fde6be6a) - kernel - vm_object work
- (7f4bfbe7) - vkernel - Partial fix to EPT swapu32 and swapu64
- (d862bd5c) - : Clean up the POSIX namespace.
- (45a53ae1) - : Generally include .
- (d3247fb9) - kernel/acpica: Include only for userland compilation.
- (98477b78) - route: addroute may change rt->rt_ifa; keep the local copy in sync.
- (e612af50) - if: Defer the if_up until the ifnet.if_ioctl is called.
- (ae18e11d) - kernel - cli interlock with critcount in interrupt assembly
- (120ac5dd) - kernel - Fix VM bug introduced earlier this month
- (490c3a2b) - Unbreak VKERNEL64 for clang compatibility.
- (c7f9edd8) - kernel - Add NUMA awareness to vm_page_alloc() and related functions
- (5a4bb8ec) - kernel - Incidental MPLOCK removal (non-performance)
- (2c9e2984) - kernel - Fix low memory process kill bug
- (d8523d49) - : Clean up the namespace a bit.
- (743146ae) - kernel - Fix atomic op comparison
- (7ea86e9d) - kernel - Remove some debug warnings for now
- (0bcd6c77) - kernel: Explicitly exclude -flto cflags for genassym.c
- (a03785a8) - iwmfw - Update to version 17 firmware for all devices supported by iwm.
- (e433596e) - : Adjust whitespace (no functional change).
- (c8f922ba) - kernel - remove mapzone
- (d0f59917) - kernel - Add some more options for pmap_qremove*()
- (5dac90bc) - kernel - Fix LOOPMASK debugging for Xinvltlb
- (cf297f2c) - kernel - Fix cluster_write() inefficiency
- (1cc73057) - kernel - kmemstatistics list wasn't MPSAFE
- (aedf5523) - kernel - Increase KVM from 128G to 511G, further increase maximum swap
- (726f7ca0) - kernel - Fix kern.proc.pathname sysctl
- (d8de7723) - style(9): Perform some cleanup in few standard headers.
- (39f23872) - : Adjust whitespace (no functional change).
- (f6a440a9) - kernel - Use _predict* in spinlock2.h
- (486b807a) - kernel - Add flexibility to the RSS rlimit
- (398af52e) - kernel - Deal with lost IPIs (VM related) (2)
- (6ecfb2fa) - : Namespace cleanup.
- (ee89e80b) - kernel - Reduce atomic ops in switch code
- (ce8b4ec1) - cpumask.h: Turn CPUMASK_ELEMENTS as implementation defined.
- (e9dd2307) - iwmfw - Fixup revert to version 16 for the 8000C firmware.
- (8f0f2b2c) - pci: Add a quirk for chips w/ broken MSI support.
- (c470b77c) - boot/libi386: Use SMAP_TYPE_MEMORY constant.
- (e2a21467) - Updates to show "4.7".
- (1887942f) - kernel - Skip vmm_shutdown() when in a panic
- (caf8d4ce) - usb4bsd: Fix compilation with -flto.
- (92914d5d) - kernel - Add kmalloc_set_unlimited()
- (c8247d06) - virtio: Fix and activate PCI MSI-X support.
- (66c5c851) - : Use _BSDVISIBLE instead of !POSIXSOURCE.
- (84bcb7f7) - wlan - Import initial full-offload scan support from FreeBSD.
- (7d86823d) - kernel - Cleanup vm_page_pcpu_cache()
- (28d45946) - kernel - Remove mplock in process trap/signal code (non-performance)
- (e1bcf416) - kernel - Refactor VMX code
- (a6225b5b) - kernel - Fix deadlock in vm_page_repurpose()
- (543e971d) - kernel - Remove some debug output
- (93c47c45) - : Bump _DragonFlyversion for binutils update.
- (b976e2c2) - sys: Extract CPUMASK macros to new
- (299f674a) - : Some POSIX adjustments.
- (2aa550cb) - kernel - Adjust vmm_guest_sync_addr()
- (8e691ff8) - Remove some old architecture handling.
- (909252eb) - syscons - Add option for the default terminal border color to kernel config.
- (44f36787) - Also add __malloclike to lint case.
- (16845406) - kernel - Incidental mplock removal
- (3091de50) - kernel - Tag vm_map_entry structure, slight optimization to zalloc, misc.
- (d3769e83) - vkernel: Add a simple pagezero() macro (unbreaks build).
- (fd4b9758) - kernel - Fix mmcsd read/write issues
- (e0bd597d) - smbfs - Fix mount_smbfs authentication error (but 'ls' still broken)
- (6f2099fe) - kernel - Add NUMA awareness to vm_page_alloc() and related functions (2)
- (f046edd0) - kernel - Prune pcpu vmzone a bit
- (e22f2acd) - kernel - Fix shared/exclusive spinlock race
- (d1ee0e77) - kernel/scsi: Do not announce pass/sg in bootverbose.
- (6737a4ff) - Clean up some more after the sys/emulation/linux removal.
- (5c13d0f3) - kernel: Use CPUSTATES constant.
- (d6e8ab2d) - kernel: Remove the COMPAT_43 kernel option along with all related code.
- (9a7c65ce) - : Style(9) fixes.
- (3e169fa5) - kernel - Enhance indefinite wait buffer error message
- (59627494) - vkernel: Add a dummy cpu_smp_stopped() function (unbreaks build).
- (6d60c55e) - boot - Fix insufficient malloc()s
- (69c8d8ed) - Correct param.h entry for this version.
- (282f3194) - kernel - Incidental MPLOCK removal
- (43fdf490) - kernel - Make kern_proc cache-friendly
- (9a4126c7) - vgapci: Remove verbose printf() messages from pci_(get/set)_powerstate().
- (2dbb2134) - usched: Fix the returned CPU affinity make by smp_active_mask.
- (3b4a3b3b) - : Add definitions of bool, true and false for the kernel.
- (2bf3efbc) - kernel - Add missing bus lock to CAM
- (4f077c8a) - kernel: Rename vm_object_init() to vm_object_init1()
- (22f4a817) - kernel - Avoid p->p_token when sending a signal to a particular lwp
- (f545b541) - kernel - Turn off pmap_dynamic_delete by default
- (68d31414) - kernel - Increase temporary bootstack
- (f4668135) - Unbreak kernel building
- (85d1c619) - if_iwm - Factor out firmware station handling into if_iwm_sta.c.
- (e5a5a436) - re: Leverage Realtek driver's chip/PHY initialization/reset.
- (f8e25fa7) - lwp: Restore lwp syscalls (except lwp_create*) declaration.
- (e0904f91) - : Rename DOSPTYP_GPT to DOSPTYP_EFI.
- (9629eb35) - kernel - Rename desiredvnodes to maxvnodes, fix deadlock
- (075c6d38) - kernel - CAM cleanup 1/N - Remove ancient scsi pccard drivers ncv, nsp, stg
- (ffa81124) - Bump _DragonFlyversion after md/crypt/ressl conflict resolution
- (3d258b72) - Use recently added attributes in few standard headers.
- (02d41d67) - kernel - refactor CPUMASK_ADDR()
- (49992e54) - Revert "kernel - Reduce priority range from dynamic priority"
- (8d6a3ef8) - kernel - Remove coredump spew on console
- (e5e174ad) - Sync ACPICA with Intel's version 20160831.
- (a9d06cca) - kernel - Fix vmspace termination race (2)
- (d1cfe63f) - iwmfw - Update 7265D and 8000C firmwares to version 22.
- (2cf1a297) - uipc: Make sure that listen is completed.
- (5ba14d44) - kernel - Remove most global atomic ops for VM page statistics
- (b67dba3c) - kernel - Fix swap issue, implement dynamic pmap PT/PD/PDP deletion (4)
- (8983ce70) - kernel - Change machdep.pmap_dynamic_delete default
- (9613a579) - boot: Use snprintf() when filling command_errbuf[] w/ dynamic content.
- (b4758707) - kernel - Disable lwp->lwp optimization in thread switcher
- (94276d26) - kernel: Remove useless if (...).
- (3aca8a44) - wlan - Don't check bgscanidle setting in net80211 for full-offload scan.
- (fd74079f) - kernel - Reduce excessive inode hash table allocations
- (ccef4b29) - kernel: fix LINT64 build after old SCSI drivers removal
- (86d59af3) - kernel - Fix races created by a comedy of circumstances (2)
- (c8d655d1) - : Add some i386 limits which libstand's strtol() needs.
- (8d4ec101) - loopback: Allow turning off RSS.
- (46ddd68f) - boot - Force -O
- (aa77d40c) - build - Fix modifying operation to /usr/obj during installworld (2)
- (c8671ca9) - kernel - Support FreeBSD style loader.conf hints for resources
- (38b5d46c) - Sync ACPICA with Intel's version 20161222.
- (f4428f2f) - kernel - Attempt to fix panic during shutdown from tmpfs
- (eebbd1f8) - Unbreak vkernel build.
- (76f1911e) - kernel - pmap and vkernel work
- (534ee349) - kernel - Implement RLIMIT_RSS, Increase maximum supported swap
- (5525fede) - kernel - Fix STOP/CONT race
- (d39bca53) - kernel - Remove global debug counters from device path
- (4a5093f7) - sys/boot: Annotate LTO issue in pxe.c
- (e47e3dba) - kernel - Fix excessive ipiq recursion (3)
- (480ed3de) - kernel - kernel - Incidental MPLOCK removal (usched, affinity)
- (95636606) - vkernel - Fix FP corruption in VMX/EPT mode
- (f603807b) - sys/dev/disk/dm: Remove dm/targets/ directory and move its entries to dm/
- (0ce37bc4) - if_iwm - Attach to new AC3168 and AC8265 chipsets (untested).
- (0caf6628) - kernel - Disallow remote growstack from procfs
- (72b7bc0a) - kernel/acpica: Fix shutdown issues with ACPICA 20161117.
- (7bf47718) - kernel/vmm - Fix build with VMM_DEBUG
- (e7d68516) - ifq: Factor out if_classq from altq_classq and use it for default ifq.
- (1eb8c611) - lwp: Add lwp_create2 syscll, which takes cpumask for scheduling.
- (c246e343) - kernel/clock: Solve aa85218e6 a bit better.
- (2d84cb50) - LTO: Prevent -flto from creating crashing kernels.
- (4373ea1c) - kernel - Change IPI recovery watchdog
- (780c2ba0) - : Fix typo in a comment (taken from FreeBSD).
- (f8bfbc51) - kernel - Incidental MPLOCK removal (non-performance)
- (95270b7e) - kernel - Many fixes for vkernel support, plus a few main kernel fixes
- (54ba75e6) - libkern: Make inet_ntoa MPSAFE by passing string buffer to it.
- (4276b194) - kernel: Add a simple kern.cp_times sysctl.
- (e08b3836) - : Clean up the namespace.
- (3533bdd2) - vkernel - Fix numerous pmap invalidation bugs
- (277350a0) - Sync ACPICA with Intel's version 20160729.
- (861a06e7) - : Some POSIX adjustments.
- (1a5c7e0f) - kernel - Refactor Xinvltlb a little, turn off the idle-thread invltlb opt
- (ba409a88) - drm: Improve integration with syscons. Move taskqueue handling to syscons.
- (56cbccaa) - kernel - Optimize lwp-specific signaling. (2)
- (98e80c61) - kernel - Fix vkernel race in host
- (8fc9d582) - kernel - Make misc crypto functions MPSAFE
- (97c8c48c) - kernel - Fix lockup due to recentn pmap change
- (739010e3) - : Remove duplicate inclusion of .
- (859c2e53) - kernel: Remove the old vx(4) network driver.
- (d2a00396) - alc: Add Killer E2500 support.
- (77df3a01) - usched: Implement LWP lazy migration support.
- (c1b9c093) - kernel/clock_gettime: Various fixes.
- (381f866e) - Unbreak buildkernel.
- (10f33427) - Bump copyrights.
- (c6a4908e) - kernel - Disable vmm by default
- (ceb0e493) - kernel - Allow VM_FAULT_DIRTY to use a shared lock
- (d555fba4) - kernel - Remove NETSMBCRYPTO option (make it the default)
- (77c48adb) - kernel - Refactor phys_avail[] and dump_avail[]
- (00eb801e) - vkernel - Adjust invalidation ABI a bit
- (616fbf75) - kernel - Add PCIER_DEVCAP2 and PCIER_DEVCTRL2 definitions to pcireg.h.
- (9f4ca867) - drm: Implement and use the Linux i2c API
- (77eaab69) - kernel - Expand p_nice effect more, fix %cpu calculation bug
- (12b70cea) - kernel - Remove ffs_rawread()
- (c0e85e96) - drm/i915: Update to Linux 4.6
- (5d302545) - kernel: Replace struct device* by device_t
- (35f0d9ff) - boot/efi: Add three new commands, efi-show, efi-set and efi-unset.
- (acb1fe1a) - drm - Fix major stalls by fixing an improper taskqueue priority
- (d3a104b2) - Numbering changes to name 4.8 branch correctly.
- (717e3e50) - kernel - Fix swap warning message when swap is full
- (352ff8bd) - drm/i915: Update to Linux 4.4
- (0062b9ff) - kernel - Remove object->agg_pv_list_count
- (699a76d9) - altq: Use microuptime() instead of microtime() - boottime.
- (f4a3095d) - Remove no longer needed include (see 075c6d38244a).
- (2739afc4) - ifq: Switch to drop-head for default enqueue method.
- (cb650b01) - if_iwm - Move Smart Fifo handling into if_iwm_sf.c, sync with Linux iwlwifi.
- (01be7a8f) - kernel - Reduce spinning on shared spinlocks
- (abc0cda7) - kernel - Reduce priority range from dynamic priority
- (679b7f0f) - Prefer to use data model (like LP64) for basic types.
- (3a3b0c3a) - kernel - vmm_init() must run after SMP startup
- (56f51086) - build - Separate out CFLAGS for kernel & module build
- (fbe96076) - kernel - Add workaround for improper yield in ACPI path
- (9800d437) - cputimer: Update comment
- (8f95cc34) - lwp: Add two syscalls to set/get lwp's CPU affinity mask.
- (a04bd7b8) - : Be more careful with _Noreturn.
- (8a5b1999) - if_iwm - Add support for Firmware paging, needed for newer 8000C firmware.
- (a55bb12d) - kernel - Incidental mplock removal - NTP support
- (c91894e0) - vkernel - Restabilize pmap code, redo kqueue, systimer, and console code
- (5ee06c6c) - kernel - Fix races created by a comedy of circumstances
- (10c39de2) - kernel - Fix indefinite wait buffer during heavy swapping
- (193c5c43) - vkernel: Fix build
- (63aaf984) - : Clean up a bit (whitespace etc.). No functional change.
- (07511847) - kernel - Fix improper dereference in the vmspace subsystem
- (1ef64a92) - : Add support for compilers -fshort-wchar.
- (dbe02471) - kernel - Refactor cpu localization for VM page allocations (3)
- (e235c57c) - param: Bump version according to the comment.
- (93d72667) - kernel/ath: Limit check index variables before using them.
- (4220cc65) - i386 removal, part 58/x: Remove .
- (bcbc8077) - : Add support for alloc_align, alloc_size and malloc attributes.
- (fda4c5f3) - kernel - Close a few SMP holes
- (895bb45a) - kernel: Fix a -Wundef warning.
- (c183e2fc) - kernel - Improve vm_page_register_action*() performance.
- (7574a3fc) - camcontrol: Force scsi_8btou64() to be inlined.
- (87f62b1c) - kernel - Fix improper mplock in mount path
- (93b54854) - kernel - Remove buffer flush debug message
- (8c6462e6) - vkernel - Save/restore errno in signal code
- (3a06728e) - kernel - Fix TDF_EXITING bug, instrument potential live loops
- (b443039b) - kernel - Augment vm_fault_page() for vkernel operations
- (7558541b) - mbuf: Factor function to set mbuf hash.
- (c6cd37a0) - vmstat - Make vmstat -m more readable
- (ddad6800) - Split out for struct termios and the flags.
- (3a609f3d) - kernel: Remove the old ep(4) and ex(4) network drivers.
- (98c1338c) - Fix VKERNEL64 build.
- (009afa1d) - kernel - Fix vmspace termination race
- (a36803d2) - kernel - Remove numerous user VM page functions
- (eb36cb6b) - vkernrel - Synchronize w/master, adjust for vmm_guest_sync_addr() changes
- (6ba5daf8) - kernel - Move vm_page spin locks from pool to vm_page structure
- (33ee48c4) - kernel - Refactor cpu localization for VM page allocations
- (c78d5661) - vkernel - Refactor pmap
- (57e09377) - kernel - Cleanup gcc warnings
- (3ddf0652) - kernel/vfs: Sort pathconf cases in the default pathconf.
- (d4d9221d) - kernel - Change vm.swapcache.use_chflags default to 0
- (9bf8c20b) - kernel - Remove unused process_exit and process_exec eventhandlers
- (3536c341) - kernel - Overhaul namecache operations to reduce SMP contention
- (a739e4f8) - kernel - Fix rare tsleep/callout race
- (e1ea8b24) - kernel - Fix a system lockup with vmm
- (4eb35779) - kernel/libiconv: Sync with FreeBSD.
- (35f74267) - boot/efi: Use strtoul().
- (aee94f86) - drm/i915: Update to Linux 4.5
- (e4b2227a) - kernel - Add missing flag to vm_page_alloc() initializer.
- (6be048a1) - sched: Add cpuset_t for FreeBSD compat
- (1b13a7e9) - kernel: Remove some ep(4) driver remains.
- (48a1ce07) - kernel - Fix machdep.pmap_mmu_optimize bug
- (ff4434f5) - kernel - Add missing p_token use in swapout scheduler callback
- (cd4cccbc) - : Move the efi_next_descriptor() macro to .
- (1019f171) - kernel - adjust sdhc timeouts, cleanup
- (de0cb18f) - : Sync enum vtagtype with what we have.
- (cff27bad) - kernel - Spiff up locks a bit
- (49525c61) - Remove . The kernel has bool etc. in now.
- (53005b09) - kernel - Fix TRIM bugs in UFS
- (3166deda) - if: Remove unnecessary critical sections.
- (07540d37) - kernel - Fix races in the vm_map and vm_object page-scanning code
- (2d418273) - Prevent dports gcc "fixing" the last headers.
- (fc531fbc) - vkernel - Fix more pagein/pageout corruption
- (dc1b9d13) - vkernel - Clock optimizations, pre-zero 'ram'.
- (63cff036) - kernel - Try to idle cpus when in panic()
- (bca42d4f) - kernel - Reduce memory testing and early-boot zeroing.
- (d0ca586a) - wlan: Remove duplicate typedef.
- (ffb0f329) - kernel/usb4bsd: Use pci_alloc_1intr() for MSI allocation in xhci_pci.c.
- (8ee19f91) - drm - Fix lock order reversal
- (5e416352) - kernel - Be nicer to pthreads in vfork()
- (9d2642a2) - firmware(9): Change type of data pointer
- (6422eba4) - kernel - CAM cleanup 3/N - Remove unnecessary mplocks
- (47491315) - kernel - Fix recursive module loading (from MPSAFE changes)
- (89393d93) - Clean up the namespace in a number of standard headers.
- (0b50ccb6) - kernel - Add trackpoint and elantech mouse support
- (a9821961) - net: Make sure that local variable is really used.
- (dc6a6bd2) - kernel - Refactor buffer cache code in preparation for vm_page repurposing
- (8178c126) - kernel - Accomodate high-ncpu + low-mem configurations
- (37795b1d) - kernel - Remove debugging kprintf
- (c50e690b) - vkernel - Change how VPTE_M works to fix seg-faults during paging
- (bbb9257c) - iwmfw - Import 7265D firmware for AC3165 and newer AC7265 revisions.
- (2d1b280f) - kernel - Cut buffer cache related pmap invalidations in half
- (96f24602) - Sync ACPICA with Intel's version 20160930.
- (791edc29) - boot/efi: Add paging to the 'memmap' and 'configuration' commands.
- (62cc5940) - kernel - Minor formatting cleanup
- (3466658c) - : Fix comments.
- (33ed2f5d) - : Bump _DragonFlyversion for global getline() visibility.
- (0e405aaf) - kernel - Remove mplock from swapon/swapoff
- (36ef29ef) - kernel - Fix kmalloc pool accounting for M_NETCRED
- (515677e1) - npx.h: fix comment alignments (cosmetic)
- (5192011a) - kernel: Mark some syscalls obsolete which are really libc functions.
- (15d6dd34) - vkernel: Make kptobj a static structure.
- (46b82de2) - vgapci: There is no drmn driver in DragonFly, there is only drm.
- (a798ebf2) - kernel: Fix stop_cpus()/restart_cpus() usages when panicing.
- (62443eb5) - kernel - Fix bug in pmap_unwire()
- (329111df) - : Use _BSDVISIBLE instead of !POSIXSOURCE.
- (a265e6dd) - buildkernel - Fix -j race
- (27bb0cf7) - i386 removal, part 55/x: Remove if_sbni(4) remains.
- (45febb32) - vkernel - Zero out memory on startup
- (de5b132c) - iwmfw - Add version 22 firmwares for AC3168 and AC8265 chipsets.
Libraries
- (dd9d57c0) - : Drop ancient guards from getline() and dprintf().
- (85ae0dce) - strftime.3: Remove extra whitespace.
- (baaf9cb9) - strptime.3: Sync with FreeBSD.
- (f7511078) - libthread_xu - Don't override vfork()
- (0fe46dc6) - build - Rewire secure, remove conflicts from libmd, libcrypt
- (a4b1d485) - libutil - Add HN_FRACTIONAL to humanize_number()
- (a886e383) - pthread: Init libthread_xu also in pthread_key_create()
- (25e1dde1) - libc/libpthread: Some manual page cleanup after the setaffinity work.
- (3dda54c6) - sysconf.3: Document SCPAGE_SIZE and SCPHYS_PAGES.
- (d3b15642) - pthread: Sync copyright changes with FreeBSD.
- (1c87de76) - xlocale: Fix type of freelocale().
- (90306d38) - pthread: Split pthread_exit() to smaller chunks.
- (b8ee06c5) - : Avoid namespace pollution.
- (4f82a29a) - lib/libhammer: Fix segmentation fault by null dereference
- (153c1b8f) - lib/libexecinfo: Fix sysctl wrong argument order.
- (ecc2e461) - libkvm - Interim solution to boost swap statistics fields
- (e5c0b1f7) - Update files for OpenSSH-7.3p1 import.
- (19da7d45) - libc/strptime: Add support for %t and %n per POSIX.
- (6be058ee) - libc - Fix more popen() issues
- (de0d9e75) - sysconf.3: Fix typo.
- (8d9431f8) - Adjust a couple of manual pages to the recent header changes.
- (fdc2e978) - libpthread: Some more adjustments for pthread_attr_setschedpolicy().
- (fd84342b) - libkiconv: Remove dead code.
- (f52b6f6b) - libc: Include for ftell/ftruncate/truncate prototypes.
- (3f81f453) - libc - Fix malloc() alignment for small allocations
- (bed5f6ef) - libdevstat: Install .so.3 into /lib to unbreak vinum(8).
- (afeec518) - libc_r: Tiny adjustment, git add.
- (b33f9840) - efivar.3: Fix prototypes in the SYNOPSIS.
- (69a95199) - Do 3b5eca529baf58ea74a485139963552cc4c1d977 a bit better.
- (798dce15) - libstand: Add -fno-builtin in case of -flto.
- (21137e2f) - libcrypt - Internalize additional symbols
- (6d1a01fe) - LIBPRIV: Introduce PRIVATELIB knob (just like INTERNALLIB).
- (8527a700) - libkiconv: Sync a bit with FreeBSD.
- (0d9899e7) - lwp: Move all lwp syscalls to sys/lwp.h
- (4a1a7880) - libedit: Trim sources that create empty objects.
- (617fc29d) - libc - restir arc4random() on fork()
- (adf9e9ed) - libusbhid: Remove some unneeded compat code.
- (46727bb0) - libc/net: Rename dprintf() to not conflict with dprintf(3).
- (2947528a) - libc - Take care of minor buffer overrun in link_ntoa()
- (1da019e7) - pthread: Use spin hint for cpu on x86_64 too.
- (20125565) - libstand: Add strtoul().
- (ceeadccd) - libc: Rip out pthread_cancel stub symbol.
- (a7477187) - libc: Add sched_getcpu().
- (7f4a69bc) - libefivar: Fix wrong MLINKS.
- (602f6c36) - tcsetattr.3: Adjust for recent termios.h changes.
- (56746faf) - mktemp.3: Improve the manpage, add mklinks.
- (f8406b33) - : Rework _weakreference() macro.
- (178a6112) - libc: Take cpusetsize into consideration for sched_getaffinity()
- (0c4f129d) - Move _weakreference() after symbols it links to.
- (808e48a1) - pthread: Collect separated mutex functions.
- (467ee1bb) - pthread: Set default contention scope to system.
- (0d2ded0f) - libstand: Add uuid_{from,to}string() and uuidcreate_nil() (from libc).
- (f02fcc43) - libc/readpassphrase: Sync with OpenBSD
- (8eddbce7) - libc: Avoid negative offsets in link_ntoa().
- (4a9b8501) - pthread: Add vprintf variant of threadprintf, reformat PANIC()
- (d4cd165b) - libsmb: Install .so.2 into /lib to unbreak mount_smbfs(8).
- (3ae362f2) - pthread: Implement pthread_attr_{get,set}affinity_np
- (43e06f64) - libusbhid: Trim sources that create empty objects.
- (930d2950) - pthread: Move out pthread_md.c from x86_64 dir to common code.
- (6be5672c) - pthread: Fix some warnings, do not raise WARNS to 6.
- (54b0dbf1) - strcoll(3): Make source compatible to more compilers.
- (da8348cb) - libc/strptime: Handle ISO 8601 time zone formats in %z.
- (602cfc0b) - pthread: Move few attr private structs to thr_init.c
- (61d257f1) - libc: Adjust Versions.def.
- (99b055ba) - libcompat: Remove various unneeded functions.
- (19451dc5) - pthread: General pre-cleanup (style, typos etc)
- (82ae7067) - Fix build with NO_OPENSSL set
- (fe54de69) - libc: Add const to the cpu_set_t for sched_setaffinity.
- (8f0a5894) - libc/strptime: Return NULL, not 0, since the function returns char *.
- (7bebe7b3) - librpcsvc: Trim sources that create empty objects.
- (a1df193d) - librt/aio: #ifndef notyet -> #if 0 /* not yet */
- (6ae02a05) - libc/getnameinfo: Whitespace fix to my last commit.
- (f93adcf6) - libncurses: Set WANRS at 5.
- (91819a48) - libpam: Trim sources that create empty objects.
- (2a028194) - mktemp.3: Fix a typo and bump .Dd
- (8289fd98) - libc: Fix up compat-43 a bit.
- (bdc0b26a) - libc/strptime: Fix "%Y %W %w %H:%M:%S".
- (6aa0e649) - libc/nmalloc: Remove some kernel code remains.
- (626c9d70) - libc/sys: Clean up Symbol.map for the recent get/setaffinity work.
- (8979fd9c) - pthread: Prefer explicit return on error.
- (3dfdf83e) - humanize_number.3: Fix typo.
- (40911a94) - build - remove whitespace
- (aec820bd) - pthread: Change single weak reference to strong one.
- (d0ce80dc) - Sync arc4random() with OpenBSD a bit.
- (b2920380) - pthread: Implement pthread_{set,get}affinity_np
- (697e5645) - LTO: Prevent -flto being used in main system libraries.
- (5270936c) - libc - Fix numerous fork/exec*() leaks, also add mkostemp() and mkostemps().
- (30cc0909) - libefivar: Remove unneeded WARNS setting (lib/Makefile.inc has it).
- (4d0d600c) - libc/strptime: Check for NULL, not 0.
- (dfa89817) - ncurses: Fix parallel buildworld race.
- (9533534e) - poll.2: Add some information about the ppoll() syscall.
- (704b9f8f) - xz: Don't use SSE headers for gcc < 5.
- (0239e277) - libmagic: Trim sources that create empty objects.
- (3c253781) - libc: Add temporary (get|set)affinity DF404.0 symbols
- (622dc5da) - libc - Include information on the 'e' flag in the popen() manual page.
- (f049c502) - pthread: Fix return value for pthread_attr_setschedpolicy()
- (e1e6cc6a) - build - Fix pam issues, fix 'su', fix libopie.
- (8d7b8f97) - xlocale: Few style(9) fixes.
- (b88e8654) - libc/strptime: Attempt to fix up %U and %W.
- (b1b85ff2) - libc: Remove the unused NO_P1003_1B variable checks.
- (5c81362c) - {rfork,setresuid}.2: Remove wrong/bogus sections.
- (a1f9998f) - pthread: Split mutex_init().
- (a0c14455) - man: Add cross references
- (2b80eaf0) - ncurses: Trim sources that create empty objects.
- (b522d718) - kernel - Minor documentation adjustment for arc4random
- (907281d1) - libc: Add sched_{set,get}affinity().
- (5f62bb52) - ipfw3: 'or' supports more filters
- (8b7469df) - sigpause.3: Add missing comma.
- (83c434b3) - libc/getnameinfo: Clean up the comments in getnameinfo_link() a bit.
- (19ba4072) - Relocate private panel library to intended location
Manual pages
- (a4653f58) - doc - Document 'crypt' option in fstab(5)
- (ca8d6047) - sys/dev/disk/dm: Sync with Linux changes in flakey read behavior
- (3d288be0) - pfil.9: Remove references to PFIL_MPSAFE (removed in 48e93b2f5147bacf8).
- (bd929a8f) - Rename cpumask.9 -> CPUMASK.9
- (499dbb9a) - Some mdoc cleanup in tuning.7 and swapcache.8
- (9801d51e) - Correct some spelling mistakes/typos in manual pages.
- (642ebfdd) - alc.4: Add Killer E2400 to the list of supported devices.
- (ae2b561c) - mbuf.9: Adjust for removal of m_devget()'s 'copy' argument.
- (97be079c) - nlookup.9: Adjust for the removal of nlookup_set_cred().
- (c280af89) - docs - Modernize swapcache(8)
- (c38bc69a) - zone.9: Adjust for the removal of the 'zalloc' arg to zinit/zinitna.
- (b7e34bd6) - build.7: Mention that KERNCONF can have more than one config.
- (f696b24f) - vmbus.4: It can be compiled into the kernel as well.
- (6ebe52f4) - fetch.9/store.9: Adjust for recent changes.
- (d195d509) - Add a uefi(8) manual page giving some info on the UEFI boot procedure.
- (92c9dfec) - Add a realquickkernel target, analogous to realquickworld.
- (86d6ddc0) - nvme - Adjust manual page
- (c5f1256b) - vkernel - Change default pre-zeroing of main memory
- (7374a7a6) - vkernel.7 - Update manual page
- (806019c7) - rc.conf.5: Adjust the memimg documentation a bit.
- (9fc561b7) - docs - Update tuning.7
- (71990c18) - Sort SEE ALSO in some manual pages.
- (abc45280) - iwm.4: Mention iwm7265Dfw firmware. Update DIAGNOSTICS section a bit.
- (08931e35) - Fix manual pages for s/struct device */device_t/.
- (86dac8bc) - rc.conf.5 - Adjust manpage to the last changes.
- (7d4c3696) - cpumask.9: Add short manpage.
- (e130a775) - zone.9: Adjust prototypes for some recent changes.
- (09ab7e4e) - i386 removal, part 56/x: Remove old i386 specific manual pages.
Networking
- (518c325f) - : Few style(9) fixes.
- (50d9e798) - : Clean up the POSIX namespace a bit.
- (c940bbfe) - tcp: Nuke the sysctl to disable local port extension.
- (87a342e7) - tcp: Save faddr/fport before lport selection.
- (7f20f9e1) - syncache: Simplify port calculation by reusing ACK's hash for IPv4.
- (75a74d21) - : Add ToS defs for RFC 2474 and 5865.
- (219503cf) - udp: Don't propagate connect error, as long as the inpcb has local port.
- (db8eaa57) - ip: Add parenthesis properly.
- (e2bf2ed2) - ip: Move multicast addresses detection into common place.
- (76a9ffca) - ip: Set mbuf hash for output IP packets.
- (9294ae32) - tcp: Fix connect to INADDR_ANY.
- (a79ef4f6) - carp: Add net.inet.carp.setroute to disable routes changes.
System configuration files and scripts
- (cb698b8d) - Add IDEA support for libcrypto(3).
- (50ffaab3) - Update the pciconf(8) database.
- (c7dd9e99) - Sync zoneinfo database with tzdata2016g from ftp://ftp.iana.org/tz/releases
- (c3288567) - Update the pciconf(8) database.
- (bf5e9998) - Sync zoneinfo database with tzdata2016j from ftp://ftp.iana.org/tz/releases
- (463e5243) - Replace binutils 2.24 with latest binutils 2.27.
- (c5450f45) - Remove the remaining traces of linux emulation.
- (7d605bf6) - Take II on fallback HOST_BINUTILSVER
- (0fcba03f) - Fix world build in NO_ALTBINUTILS edge case
- (a74d5292) - Update the pciconf(8) database.
- (1fcff771) - i386 removal, part 54/x: Remove perfmon(4) remains.
- (2b1d5679) - rc.d - Follow up previous commit
- (9ef43fc3) - Clean up a bit after the recent CAM work (075c6d38244abd0b0c8).
- (87d7235e) - Update the pciconf(8) database.
- (5cc5a38c) - Switch to binutils227 as default base binutils.
- (d2195e48) - binutils225: Add bfd-plugins directory to mtree.
- (b3c6ec2b) - sys.mk: Introduce WORLD_CCOPTLEVEL.
- (f357dbd4) - bsd.sys.mk: Make build permissive for pre gcc 5 compilers.
- (eae3703b) - Add entries for initial clang import in mtree.
- (3d5b69d3) - bsd.crunchgen.mk: Remove dub handling of CANONICALOBJDIR.
- (6dba70ef) - bsd.crunchgen.mk: Split few monolitic targets.
- (a512831c) - rc.subr: Add ${name}env and ${name}prepend.
- (3b5eca52) - Adjust various things after the removal of secure/.
- (55cd48f3) - bsd.crunchgen.mk: Use single style for variables.
- (9d53bd00) - rconfig: Add a script for setting up a HAMMER/UEFI system.
- (5d6d7712) - sys.mk: Introduce WORLD_CFLAGS.
- (cfffedae) - Update the pciconf(8) database.
- (579f6fcc) - bsd-family-tree: Sync with FreeBSD (various NetBSD versions).
- (ada4dfeb) - Bring in uefisign(8) example script.
- (8d7da424) - Revamp alt compiler handling for clang 3.9.1 import.
- (796a448c) - bsd-family-tree: Sync with FreeBSD (FreeBSD 11.0).
- (7a13f593) - Remove /usr/include/readline from mtree too.
- (32733d8d) - rc.d - Allow vkernel to run as non-root
- (82a792ca) - bsd.sys.mk: Make buildworld permissive for -Os and -Og.
- (cdab4658) - Update the pciconf(8) database.
- (259eb49b) - Prevent implicit -std=* passing from NXCFLAGS to NXCXXFLAGS.
- (cd98845a) - Sync zoneinfo database with tzdata2016i from ftp://ftp.iana.org/tz/releases
- (2eaf5a41) - installer: Fix the "missing /var/run/sem" issues better.
- (6954d52d) - Prevent implicit -Wsystem-headers passing from CFLAGS to CXXFLAGS.
- (54a16403) - bsd-family-tree: Sync with FreeBSD.
- (adfb2c71) - Step 1/2 of OpenSSL remove: Suppress building
- (fc413054) - Sync zoneinfo database with tzdata2016h from ftp://ftp.iana.org/tz/releases
- (0e767a30) - bsd.crunchgen.mk: Simplify mk logic a bit.
- (105b5cd2) - rc.d - Add option to load kernel modules from rc.conf(5)
- (4ade232d) - rc.d - Add an option to specify memimg file for vkernels
- (df905be9) - bsd.libnames.mk: Remove outdated XXX.
- (33d7ed01) - build - Add support for new NO_* make variables
- (e9597fea) - rc.d - Make sure rootimgs are empty for every vkernel
- (83b0991f) - Sync zoneinfo database with tzdata2017a from ftp://ftp.iana.org/tz/releases
- (7efec73e) - Clean up a bit after the recent ahc/ahd/aic removal.
- (c0bd4906) - Remove NO_OPENSSH variable functionality
- (dc81b981) - bsd.crunchgen.mk: No longer exclude -P option.
- (8762287a) - Add private versions of libcrypto and libssl (LibreSSL v2.4.2)
- (5fa549ce) - bsd-family-tree: Sync with FreeBSD (OpenBSD 6.0).
- (d98aab42) - examples/rconfig: Fix CD/PXE check in two scripts.
- (31492c87) - Update the pciconf(8) database.
- (6b6525b6) - bsd-family-tree: Sync with FreeBSD (DragonFly 4.6.0).
- (874f7ebe) - bsd.sys.mk: Exclude PROG from PHONY list.
- (61fb4aca) - rc.d - Use kldstat -m to test existance before kldload
System utilities
- (6acc1a36) - sbin/hammer: Add blockmapxlateto_zone2() to refactor get_buffer()
- (d687695e) - sysctl(8): Fix types of structure format functions.
- (e0c64b7d) - sbin/hammer: Remove unused AssertOnFailure
- (a4cb163f) - sbin/newfs_hammer: Add assertion for header junk space size
- (02971442) - sbin/hammer: Use "objid" for inode#
- (ebf2c18a) - sbin/hammer: Fix default behavior of init_{boot,mem}areasize()
- (ce6ddec9) - sbin/hammer: Don't expose softprune specific data structure
- (871ff6cb) - sbin/hammer: Directly access volume in volume list
- (1c3b0e82) - dmesg.8: Improve markup a bit and fix a typo (dumnr -> dumpnr).
- (02318f07) - sbin/hammer: Change fprintf/exit to err variants [2/2]
- (a8abc07e) - sbin/hammer: Add allocbuffer() to refactor getbuffer()
- (dce7ae2c) - sbin/hammer: Add print_blockmap() for common blockmap output format
- (f4bb1f26) - sbin/hammer: Change fprintf (without exit) to err variants
- (8b30142b) - sbin/hammer: Fix wrong error message
- (1b9a5070) - installer: Turn off soft updates for /boot in the UFS install.
- (7eb492eb) - sbin/newfs_hammer: Remove \n from errx(3)
- (b480bc95) - sbin/hammer: Fix hammer show-undo output format
- (830ab40e) - sbin/hammer: Redo e4323571 partly (after reverted by 03d5db37)
- (f252c9b0) - newfs_msdos(8): Sync with FreeBSD.
- (c3e30e91) - sbin/hammer: Remove \n from err(3)/errx(3)
- (2dd9a2a5) - sbin/hammer: Partly revert 2c1d3cef in 2010
- (6e6c5405) - ssl: Consistently use LibreSSL base headers.
- (c6bbcd25) - build: Fix wrong DPADD for libcrypto.
- (c3cfd6ce) - sbin/newfs_hammer: Don't bother initializing reserved ondisk field
- (a19bad89) - sbin/hammer: Increment recovery scan offset regardless of get_buffer() result
- (0de090e1) - build - prepare for higher optimization levels
- (ba851a8a) - restore(8): Fix formats in prints.
- (95f03e3e) - sbin/newfs_hammer: Use warn(3) variants
- (61940690) - sbin/hammer: Make getdir() support more than 1 trailing /
- (c6c4cbd9) - sbin/hammer: Remove rel_volume()
- (25ee129e) - sbin/newfs_hammer: Add -C option from hammer(8)
- (21000e42) - sbin/hammer: Make struct volume_info::name const
- (7dae739f) - installer - Fix a bug in survey_storage()
- (21e9e7d5) - sys/vfs/hammer: Use typedef'd for struct hammer_blockmap_xxx*
- (f402100c) - sbin/hammer: Fix irrelevant comments
- (c57d99af) - sbin/newfs_hammer: Fix remaining one from 3e7805d7
- (00dd9c67) - sbin/hammer: Minor hammer show cleanups
- (8d378610) - tcpdmatch(8): Honor global CFLAGS.
- (03d5db37) - Revert "sbin/hammer: Fix bug in get_buffer_data()"
- (7603683a) - sbin/hammer: Make use of struct buffer_info::cache at offset 0
- (83baa772) - sbin/quotacheck: Rename maxino to remove globals conflict.
- (be813d7a) - Remove portal file system, mount_portal and examples.
- (0e777cf7) - sbin/hammer: Always call check_volume()
- (578f0d56) - sbin/hammer: Partly revert 8b640662 in 2014
- (c34b3562) - sbin/hammer: Minor cleanup for hammer recover
- (71db84da) - sys/vfs/hammer: Use typedef'd for struct hammer_inode_data*
- (304ca408) - Switch base to use private LibreSSL libaries
- (4e8098b2) - sys/vfs/hammer: Add HAMMER_FSTYPE_STRING
- (7f56be5f) - sbin/hammer: Make get_buffer() static
- (ed27c2d1) - powerd - Detect power state changes
- (3367f3b3) - sys/vfs/hammer: Use typedef'd for struct hammer_node_ondisk*
- (83cc8a91) - mtree(8): Use getcwd().
- (f7077dee) - setkey(8): Fix m_len type to match real one.
- (1b23fc22) - sbin/hammer: Add clrpfs()
- (dc17a1e0) - sbin/hammer: Use dirname(3) instead of getdir() in scanpfsid()
- (b157444a) - sbin/hammer: sbin/hammer: Fix hammer show-undo output format
- (4d8a2348) - sbin/newfs_hammer: Cleanup
- (19836c70) - sys/vfs/hammer: Add HAMMER_UNDO_DOALIGN()
- (3badf6b7) - dma - Fix security hole
- (9221b598) - sbin/hammer: Add assert_volume_offset()
- (dd96867b) - sbin/hammer: Cleanup zone statistics
- (f2c24df8) - dntpd - Fix memory leak
- (1b1c194d) - sbin/newfs_hammer: Refactoring
- (6ab64ab6) - installer - Reorganize test directory a bit
- (a2cc732c) - sbin/hammer: Remove default volume initialization from alloc_bigblock()
- (02f3d2d0) - installer: Fix typo in handling null mounts array.
- (c03b793e) - sbin/hammer: Fix recursively called hammer_parsedevs()
- (927812a6) - sbin/hammer: Fix print_blockmap() for non-root volume
- (c4f94769) - sbin/hammer: Add debug prints while scanning node during recovery
- (cf7697c2) - Fix two typos in manual pages.
- (fc124603) - sbin/hammer: Remove if(QuietOpt) conditionals in hammer show/checkmap
- (27242c33) - sbin/hammer: Don't use hard-coded 1024 for # of layer1 per volume
- (eee3f66c) - sys/vfs/hammer: Use HAMMER_OFF_{SHORT,LONG}_ENCODE()
- (9ca03654) - sbin/hammer: Fix direntry message in hammer recover
- (1ba4249f) - sbin/hammer: Remove get_node()
- (9b6e7743) - sys/vfs/hammer: Use hammer_is_zone_xxx()
- (37a7a073) - sbin/hammer: Add another condition to assert_volume_offset()
- (a9785ff9) - sbin/hammer: Cleanup alloc_blockmap()
- (79e13087) - sbin/hammer: Remove redundant blockmap lookup in hammer show
- (ebbcf693) - Link mount_msdos(8) dynamically.
- (c6f0ed7d) - sbin/hammer: Cleanup blockmap_lookup()
- (ef1d1012) - sbin/newfs_hammer: Fix print_volume() for non-root volume
- (184aa224) - sbin/hammer: Use HAMMER_OBJID_ROOT
- (1e297b34) - sbin/mount_hammer: Fix/cleanup test_volumes()
- (c3576865) - restore(8): General cleanup.
- (d846dce0) - sbin/hammer: Rewrite hammer bstats/iostats
- (16712f18) - sbin/hammer: Fix memory leak
- (522fafa8) - sbin/hammer: Mark few functions as always inlineable.
- (fd102df4) - sbin/hammer: Don't wait 5 secs on pfs-destroy if -d (for devs)
- (7b1aa074) - installer: Add basic UEFI system setup.
- (173bd31c) - sbin/hammer: Don't expose VolList
- (5d1ffe69) - devd(8): Remove build workaround.
- (45643966) - sbin/hammer: Use inline CRC functions in userspace
- (d1918246) - efivar.{3,8}: Fix some mdoc issues.
- (affce8d3) - sbin/hammer: Change "PFS #" to "PFS#"
- (2eccaef5) - sbin/hammer: Add hammer strip command
- (ea458aa6) - sbin/hammer: Don't include libhammer.h unconditionally
- (d454cd69) - sys/vfs/hammer: Add HAMMER_VOL_JUNK_SIZE/HAMMER_{MIN,MAX}VOLJUNK
- (8c579f0a) - restore(8): Use size_t were appropriate.
- (759d6d28) - sbin/hammer: Fix inode/data messages in hammer recover
- (fa9d9a9c) - sbin/hammer: Add "[y/n]" before getyn()
- (b3dd5035) - sbin/hammer: Add volume signature check on loading a volume
- (b93d6cf8) - tmpfs - Fix mount_tmpfs -C
- (2252fcf8) - sbin/hammer: Use HAMMER_ENTRY_NAME_OFF
- (385a0260) - sbin/hammer: Cleanup arguments of init_volume()
- (63965540) - routed(8): Remove SGI specific code.
- (6d584f65) - sbin/newfs_hammer: Replace hard-coded 512MB/1GB strings with sizetostr()
- (a1ef4f7e) - sbin/hammer: Add verify argument to load_volume()
- (3d900665) - sbin/hammer: Add full mode for hammer recover to revive full scan
- (8be10271) - installer - Enhance test_storage program
- (4a2f6348) - sbin/hammer: Make hammer_parsedevs() take open(2) flag
- (c5792f02) - sbin/newfs_hammer: Add exit_code arg to usage()
- (efcc709c) - i386 removal, part 59/x: Revert a i386 specific local change in dma(8).
- (c6434d78) - powerd - Add temperature-based management
- (be541fc2) - sbin/hammer: Sync zone statistics format with print_blockmap()
- (920e34fa) - sbin/mount_hammer: Simplify ondisk verification
- (6c7ae023) - sbin/hammer: Remove hammer_cache_set()
- (5fee6e9a) - sbin/hammer: Abort if failed to creat recover target dir
- (bb7548fd) - efi - Add EFI run-time ABI support
- (40649c3e) - sbin/hammer: Return -1 if readlink(2) failed
- (99c8e8ab) - ppp(8): Remove useless POSIXSOURCE checks (no functional change).
- (20cd7985) - restore(8): Fix extern type mismatch.
- (7b21e84b) - installer: Rename is_livecd -> is_installmedia.
- (ce1bcb9e) - mountd, mount - Change how mount signals mountd, reduce mountd spam
- (af78dcb9) - sbin/hammer: Remove redundant volume arg in find_buffer()
- (93056456) - sbin/hammer: Refactoring
- (5edbfae8) - md5 - Fix seg-fault
- (bab16452) - sbin/mount_hammer: Fix warning messages
- (5da26eaf) - sbin/hammer: Cleanup blockmap
- (684002f2) - sbin/hammer: Cleanup struct volume_info
- (01578864) - restore(8): Fix and enable WARNS.
- (4cda1b5c) - kernel/efi: Add a sysctl machdep.efi_map to dump the raw EFI memory map.
- (2615c079) - sbin/hammer: Cleanup hammer show-undo
- (642d73b8) - sbin/hammer: Fix rename printfs to differentiate recover paths
- (d8d65438) - talkd(8): Avoid warning on gcc with -flto.
- (6d52f9f2) - sbin/hammer: Move pidfile_loc[] to hammer.h
- (ce5eb8e9) - sbin/newfs_hammer: Fix newfs_hammer(8) manpage
- (935c61ab) - sbin/newfs_hammer: Set HAMMER_OBJTYPE_DIRECTORY for ondisk PFS#0 data
- (4006d7d7) - installer: Fix comment typo.
- (202c7c8d) - sbin/hammer: Cleanup hammer recover
- (d6c59c72) - sbin/hammer: Don't print mountpoint of PFS
- (445b5ba6) - sbin/hammer: Cleanup getpfs()/scanpfsid()
- (f2dd4b0c) - sbin/hammer: Mention bug in hammer recover command
- (fdba9548) - sbin/hammer: Use . for pfs-status if no arg
- (5bdb9719) - mount_cd9660(8): Add -b and -j to usage().
- (8b916bc2) - sbin/hammer: Add a trivial wrapper over blockmap_lookup()
- (9bb1cf1e) - sbin/newfs_hammer: Mention root volume is volume#0 in manpage
- (62997e7b) - sbin/hammer: Use HAMMER_BUFSIZE to calculate CacheMax
- (143ed6ad) - rtld: Fix handling of DT_TEXTREL for object with multiple read-only segments.
- (95c30c8c) - sbin/newfs_hammer: Fix low limit of -b and -m option
- (a5ff7917) - sbin/hammer: Don't hardcode 0 for root PFS
- (a1c3132e) - sbin/hammer: Minor fix for hammer recover quick mode
- (0942cbbc) - sbin/hammer: Fix terminology of buf_offset
- (81a213a5) - sbin/newfs_hammer: Check/initialize uuid after getopt
- (476c0f69) - tcpdchk(8): Honor global CFLAGS.
- (825a2db2) - sbin/newfs_hammer: Allow 0 for boot_area/memory_log size [1/3]
- (1bb4c83b) - mtree(8): Fix wrong extern.
- (9ca52568) - sbin/hammer: Use HAMMER_BTREE_TYPE_RECORD
- (5b334df8) - sbin/hammer: Make hammer show-undo support zone statistics
- (74087558) - sbin/hammer: Test high limit in init_{boot,mem}areasize()
- (28b9bac3) - sbin/hammer: Move hammer_btree_cmp() to cmd_show.c
- (281de955) - sbin/hammer: Refactor hammer_cache_flush()
- (f03bf307) - sbin/newfs_hammer: Check maximum undo fifo size with explicit error message
- (ce410fe9) - sbin/hammer: Fix whitespace alignment changed by e0d7dd09
- (09e40bf3) - sbin/hammer: Remove getdir()
- (8679ed64) - sbin/hammer: Move score_printf()/hammer_check_restrict() to cmd_mirror.c
- (f831b060) - sbin/hammer: Refactoring
- (c98d4740) - config(8): Comment out some linux emulation remains.
- (13846824) - sbin/hammer: Use int64_t for zone stats blocks/items/used
- (9376f71b) - sbin/hammer: Don't ioctl(SET_PFS) before attempt to destroy PFS
- (e8faee88) - LIBPRIV: Add private includes for dfuife_curses.
- (f3c08aaa) - sbin/hammer: Refactor left/right boundary elms in hammer show
- (5edcf928) - sbin/hammer: Minor cleanup for hammer blockmap
- (4c18cb16) - sbin/hammer: Make blockmap.c/misc.c include hammer_util.h (not hammer.h)
- (8a05145d) - sbin/hammer: Sync dce7ae2c format with zone statistics
- (b430ae87) - build - prepare for higher optimization levels (2)
- (8ecda427) - sbin/newfs_hammer: Allow 0 for boot_area/memory_log size [2/3]
- (46e9f340) - sys/vfs/hammer: Use typedef'd for struct hammer_snapshot_data*
- (79b114a0) - sbin/hammer: Use big-block append offset to limit recovery scan range
- (591440d1) - sbin/newfs_hammer: Add -h option
- (441e6e18) - svc(8): Link as static.
- (30e8ae55) - sbin/hammer: Split alloc_bigblock() into two functions [1/2]
- (25abdf3e) - sbin/mount_hammer: Use warn(3) variants
- (14331391) - sbin/hammer: Remove meaningless sscanf for "@@PFS%d" format
- (2eeb975d) - restore(8): Remove (void *) casts.
- (cb740add) - ssl: Unhook internal usage of include/openssl/.
- (c8f165e2) - sbin/hammer: Properly use calloc(3)
- (f04399b1) - sys/vfs/hammer: Rename HAMMER_UNDO_LAYER2 to HAMMER_MAX_UNDO_BIGBLOCKS
- (044711a6) - sbin/hammer: Cleanup sbin/hammer/hammer_util.h
- (f3f3fa72) - sbin/newfs_hammer: Link against sbin/hammer/misc.o
- (3568afc1) - installer: Init payload to NULL.
- (3a47b322) - sbin/hammer: Drop bug fix by 750beaef after 9376f71b
- (f5280412) - sbin/hammer: Remove XXX in a comment
- (52f06bfd) - Fix some typos in manual pages.
- (38f16a2d) - sbin/hammer: Make get_node() a wrapper over get_buffer_data()
- (e827d884) - sbin/hammer: Remove redundant cache counter NCache
- (6153075a) - sbin/hammer: Use calloc(3) instead of malloc(3)+bzero(3)
- (5dce36ed) - sbin/hammer: Fix typo from 14331391
- (cb86d4af) - ppp: Avoid gcc warnings.
- (668f11d8) - sys/vfs/hammer: Add HAMMER_MIN_UNDO_BIGBLOCKS to set minimum undo fifo to 512MB
- (0b674f74) - Add HISTORY sections in most sbin/ manual pages.
- (fb42c274) - sbin/hammer: Fix known bug in full scan recovery mentioned in f2dd4b0c
- (3f55980b) - sbin/hammer: Make sizetostr() print B if <1KB
- (e671cfa6) - sbin/hammer: Fix/remove redundant error variable
- (cae2835b) - Rename getline with get_line to avoid collision with getline(3).
- (4d4ae2fa) - installer - Allow to specify cmdnames file path
- (ec206eb9) - sbin/hammer: Remove redundant ioctl(GET_PSEUDOFS) call in getpfs()
- (2998e5e0) - sbin/mount_hammer: Add missing switch case from bab16452
- (31222e7c) - sbin/hammer: Remove unused zone field in struct zone_stat
- (87a5b325) - sbin/newfs_hammer: Add printf for HAMMER version after formatting
- (0519bef5) - sbin/hammer: Remove alloc_data_element()
- (e4323571) - sbin/hammer: Fix bug in get_buffer_data()
- (20f1a07f) - sbin/newfs_hammer: Fix source for filesystem info after formatting
- (3e7805d7) - sys/vfs/hammer: Rename mem_area_size to memory_log_size
- (bac217f3) - sbin/hammer: Change fprintf/exit to err variants [1/2]
- (278713ff) - Add a minimal nvmectl(8) manual page.
- (9dfd60d1) - sbin/hammer: Split alloc_bigblock() into two functions [2/2]
- (9a4f151e) - sbin/hammer: Sync return value of test_btree_search() with hammer_btree_cmp()
- (4086570b) - installer: Fix source directory specification.
- (e819b271) - sbin/hammer: Add quick mode for hammer recover
- (c2b74c42) - sbin/hammer: Make hammer recover use hammer_parsedevs_noverify()
- (22b23697) - sbin/hammer: Remove get_ondisk() after previous commits
- (c12351c5) - sbin/hammer: Add verbose volume message while recovering
- (e3cefcca) - sbin/hammer: Use last active big-block to limit recovery scan range
- (5bbf2e86) - sbin/hammer: Cleanups
- (420829c2) - sbin/hammer: Cleanups
- (74e22fd6) - mlxcontrol(8): Provide defaults to few variables.
- (8afa51ff) - Wipe the start of the disk when formatting the disk with MBR, too.
- (72e23ddf) - sbin/hammer: Remove AssertOnFailure assertion in blockmap lookup
- (938e7d42) - devd(8): Make it possible to compile with LTO.
- (3cbed770) - mount_{cd9660,ntfs}(8): Link dynamically to enable -C again.
- (73eb8826) - sbin/hammer: Rename alloc_btree_element() to alloc_btree_node()
- (6adb5810) - sbin/hammer: Add inode size check to hammer show
- (e2052dd5) - sbin/newfs_hammer: Allow 0 for boot_area/memory_log size [3/3]
- (a60bc03f) - df, pstat - Use HN_FRACTIONAL
- (4e8ef5c1) - dntpd: Fix typo.
- (30457c93) - sbin/hammer: Add a TODO comment for hammer recover
- (b2290779) - sbin/newfs_hammer: Add -d option from hammer(8)
Tools
- (dbeb2594) - tools/kq_sendcli: Add sendfile support.
- (12439f34) - tools/kq_sendrecv: Fix building on FreeBSD
- (a33ac161) - test - Add umtx1 code
- (b747e370) - tools/kq_recvserv: Add option to enable SO_REUSEPORT
- (a06d7982) - tool/kq_sendcli: Add option to set write size.
- (867a0dcb) - tools/kq_recvserv: Add option to set receiving thread's CPU affinity.
- (73d83e2b) - pktgen: Ifnet lock is required by ifunit.
- (28da9003) - test/udp: Add echo test for connected->disconnected socket.
- (de05ab5f) - test/passdesc: Allow specifying the payload length.
- (8cdef6cb) - kernel - Increase worst-case maximum exec rate
- (2ef463d8) - tools/kq_recvserv: Add option to set read size
- (01030887) - fsstress - Fix compiler warning
- (2fe73a22) - tools/kq_sendcli: Add option to set sending thread's CPU affinity
- (6052a76a) - debug - Update kmapinfo, zallocinfo, slabinfo
- (d0128b6a) - test - Adjust blib and sc1
User utilities
- (c0f2d562) - vmstat - (-m) Make large values more readable
- (a185edbf) - flex: Rename and install the main libl.a as primary one.
- (f6d8f5bc) - build - Fix bootstrap build for csh
- (82f8b550) - systat - Restrict %rip sampling to root
- (018662b5) - systat - Refactor memory displays for systat -vm
- (03b4f17c) - sed(1): Fix issue with basename()/dirname() invoke.
- (f1a830e3) - install(1): Silence false gcc warnings.
- (9e2a88e3) - Raise WARNS to 3 for sftp(1) and sftp-server(8).
- (94400e62) - sort(1): Fix some obvious issues
- (7d462af5) - bsd.crunchgen.mk: Sync with FreeBSD.
- (07ed7d32) - localedef: Fix ctype dump (fixed wide spread errors)
- (6c9f93de) - csh(1): Allow to bootstrap with -flto.
- (8e57c7e6) - tic(1): Add missing beforedepend for termsort.c.
- (07774aea) - sort - Don't live-loop threads
- (44753b81) - usr.bin/rfcomm_sppd: Avoid gcc warnings.
- (6705808d) - systat - enhance interrupt display
- (92e10cbe) - ed(1): Sync with FreeBSD.
- (52bed69f) - systat(1): Fix curscale type to match other one.
- (4e30bdab) - Add/fix some HISTORY sections in bin/ manual pages.
- (e3989b5e) - nc(1): Adjust makefile and hook into buildworld.
- (c3c34e5f) - vmstat - Adjust headers
- (5fdc394b) - cal(1): Avoid gcc warnings.
- (9053551a) - bootstrap: Add workaround for chflagsat() from 4.0.
- (e93ede06) - users(1): Avoid gcc warning.
- (875016c4) - Expose ld.bfd and ld.gold
- (006835dc) - vmstat - Revamp output
- (a78dfe84) - Unbreak world after make upgrade REMOVE_OPENSSL_FILES=yes.
- (ae24b5e0) - cpdup: When verbose, also log the successful creation of a directory.
- (2078ed4a) - telnet(1): Fix line definition to match extern one.
- (96ce82a2) - systat - Adjust extended vmstats display
- (bc9b7439) - df.1: Fix example for -t. It's null, not nullfs.
- (da129953) - xargs - Add dummy -r option
- (181061dc) - gencat(1): Limit and mark bootstrap hack.
- (00dca917) - buildworld - bootstrap compatibility compiling older DragonFly's
- (7f38fe7b) - Use instead of the deprecated .
- (7286ac24) - wall(1): Avoid gcc warning.
- (9d6cd601) - nvi: Convert catalog creation to use hostprog.
- (87df5a71) - crunchgen(1): Switch to use cc for ld.
- (d0b2ff83) - i386 removal, part 57/x: Remove two i386 leftovers.
- (38b720cd) - LIBPRIV: Add common PRIVATELIB_LDFLAGS definitions.
- (7608722c) - chmod.c: Remove mention of POSIX in a comment.
- (5719210c) - systat - enhance interrupt display (2)
- (61830beb) - vmstat - Make vmstat -m more readable (2)
- (649d8aa3) - sdpquery(1): Remove an unneeded explicit -Wno-unused-but-set-variable.
- (779c5f44) - ps - Adjust STATUS formatting
- (b5302a4e) - crunchgen(1): Fix few spurious warnings.
- (7c315537) - ed(1): Remove handling of non-POSIX environment.
- (dec41b76) - less(1): Upgrade from 471 to 481
- (f2a91d31) - Remove usage of WITHGETLINE and WITHDPRINTF.
- (423ad346) - tic(1): Restrict termsort.c hack to btools.
- (077be2d6) - znew(1): Convert to use sh.
- (13c1262e) - flex: Disable LTO in the libfl.a for clang.
- (23c84b8f) - localedef: Improve cc_list parsing
- (7c1d4c2c) - xargs.1: Add some words about -r (taken from FreeBSD).
nrelease
- (5fa778d7) - nrelease: Add UEFI mode capable boot media.
other
- (97e7128f) - make upgrade: Remove one more file I forgot in 859c2e538.
- (f30cf7c7) - : Always inline functions.
- (3ad7aa9c) - Remove old timezone Pacific/Johnston via 'make upgrade'.
- (57eefc0b) - Update files for OpenSSL-1.0.2h import.
- (c49e47af) - : Explicitly add va_list definition.
- (4b68a649) - Adjust whitespace in a couple of standard headers (no functional change).
- (08fafda6) - i386 removal, part 60/x: Generalize a buildkernel error message a bit.
- (96145268) - : Fix namespace pollution from
- (b9df5afa) - build - Fix nativekernel build
- (d4a1c427) - : Fix va_list visibility.
- (f49f5f10) - Remove old timezone via 'make upgrade'.
- (94c1145b) - : Adjust the visibility of CLOCK_REALTIME and TIMER_ABSTIME.
- (74d54042) - Always use unix line endings
- (006484f4) - : Mark some __nonnull(x) cases.
- (47b765aa) - UPDATING: Add note for OpenSSH HPN removal
- (04f207b3) - libssh: Trim sources that create empty objects.
- (521f740e) - Run make depend in quickkernel, too.
- (1221f4de) - WORLD_CCOPTLEVEL: Unbreak world at -O2
- (d3b95ee1) - : Change visibility of va_copy().
- (891976b0) - Fix typo.
- (d068bc21) - : Perform some style(9) cleanup.
- (136141ba) - build: Suppress exessive echoing.
- (d2475d7d) - Fix typo.
- (fc84f547) - : Visibility changes.
- (adb513f0) - kernel - CAM cleanup 2/N - adjust make upgrade
- (be369784) - : Add max_align_t guards for future reference.
- (d6fa034f) - : Change visibility of few POSIX extensions to ISO C.
- (9e8e4b87) - make upgrade: Remove no longer existing manpages after the OpenSSL upgrade.
- (c00641ef) - xlocale: Fix LC_*_MASK bit shifting.
- (b345f56c) - : Fix MB_CUR_MAX return type.
- (4432df4a) - libcrypto(3): Set CC variable for Perl scripts.
- (defad9da) - Remove dead /usr/include/compat symlink, too.
- (f09ee2ea) - Remove duplicate XAUTH_PATH handling
- (778bd925) - Remove profiled version of libraries too.